1 { pkgs, lib, config, nixosConfig, ... }:
11 pkgs.gnome.dconf-editor
12 pkgs.hicolor-icon-theme
19 #services.gnome.at-spi2-core.enable = true;
20 home.sessionVariables = lib.mkIf (!nixosConfig.services.gnome.at-spi2-core.enable) {
23 services.redshift.enable = lib.mkDefault true;
24 # keycode <num> = <x> <Shift+x> _ _ <AltGr+x> <AltGr+Shift+x> _ _"
25 home.file.".Xmodmap".text = ''
26 ! — (tiret insécable) with AltGr+Shift+-
27 keycode 15 = minus 6 bar fiveeighths bar U2011
28 ! — (tiret cadratin) with AltGr+Shift+_
29 keycode 17 = underscore 8 bar fiveeighths backslash emdash
31 ! Œ with AltGr+Shift+o
32 keycode 32 = o O o O oe OE
33 ! … (ellipsis) with AltGr+;
34 keycode 59 = semicolon period comma less ellipsis multiply ccedilla Ccedilla
35 ! (nbsp) with AltGr+space and (narrow nbsp) with AltGr+Shift+space
36 keycode 65 = space space NoSymbol NoSymbol nobreakspace U202F
38 systemd.user.services.setxkbmap.Service.ExecStartPost =
39 "${pkgs.xorg.xmodmap}/bin/xmodmap ${config.home.homeDirectory}/.Xmodmap";
40 programs.bash.shellAliases = {
41 gtk-light = "dconf write /org/gnome/desktop/interface/color-scheme '\"prefer-light\"'";
42 gtk-dark = "dconf write /org/gnome/desktop/interface/color-scheme '\"prefer-dark\"'";
45 "org/gnome/desktop/interface" = {
46 color-scheme = "prefer-dark";
50 theme.name = "Adwaita";
51 gtk2.configLocation = "${config.xdg.configHome}/gtk-2.0/gtkrc";
53 bookmarks = lib.mkDefault [