11 ../nixos/profiles/debug.nix
12 ../nixos/profiles/graphical.nix
13 ../nixos/profiles/irssi.nix
14 ../nixos/profiles/lang-fr.nix
15 ../nixos/profiles/laptop.nix
16 ../nixos/profiles/printing.nix
17 ../nixos/profiles/radio.nix
18 ../nixos/profiles/tor.nix
19 ../nixos/profiles/bluetooth.nix
20 ../nixos/profiles/home.nix
25 pumpkin/networking.nix
28 # Lower kernel's security for better performances
29 security.kernel.mitigations = "off";
31 home-manager.users.julm = {
32 imports = [ ../homes/julm.nix ];
35 openssh.authorizedKeys.keys = map lib.readFile [
36 # For nix -L run .#pumpkin.switch
37 ../users/julm/ssh/pumpkin.pub
43 # Put the hashedPassword in /nix/store,
44 # though /etc/shadow is not world readable...
45 # printf %s $(mkpasswd -m md5crypt)
46 hashedPassword = lib.readFile pumpkin/users/julm/login/hashedPassword.clear;
52 "plugdev" # For rtl-sdr
59 config.services.davfs2.davGroup
62 # If created, zfs-mount.service would require:
63 # zfs set overlay=yes ${hostName}/home
65 openssh.authorizedKeys.keys = map lib.readFile [
66 ../users/julm/ssh/losurdo.pub
73 #"http://nix-localcache.losurdo.sp"
74 #"file:///mnt/off4/julm/nix?priority=10&trusted=true"
75 "ssh://nix-ssh@losurdo.sp?priority=30"
77 trusted-public-keys = map lib.readFile [
78 ../users/nix/ssh/losurdo.pub
81 nixPath = lib.mkForce [ "nixpkgs=${inputs.nixpkgs}" ];
83 #environment.etc."nixpkgs".source = pkgs.path;
84 #environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
86 nix.settings.allowed-users = [
87 #config.users.users."nix-ssh".name
91 keys = map lib.readFile [
92 ../users/julm/ssh/losurdo.pub
93 ../users/julm/ssh/pumpkin.pub
94 ../users/sevy/ssh/patate.pub
98 environment.systemPackages = [
99 #pkgs.riseup-vpn # Can't be installed by home-manager because it needs to install policy-kit rules
102 boot.extraModulePackages = [
103 #config.boot.kernelPackages.v4l2loopback
106 programs.fuse.userAllowOther = true;
108 services.davfs2.enable = true;
110 systemd.automounts = [
112 where = "/mnt/aubergine";
113 automountConfig.TimeoutIdleSec = "5 min";
118 # Use the user's gpg-agent session to query
119 # for the password of the SSH key when auto-mounting.
120 sshAsUser = pkgs.writeScript "sshAsUser" ''
122 exec ${pkgs.sudo}/bin/sudo -i -u "$user" \
123 ${pkgs.openssh}/bin/ssh "$@"
130 "exec" # Override "user"'s noexec
134 "ssh_command=${sshAsUser}\\040julm"
137 "x-systemd.automount"
138 #"Compression=yes" # YMMV
139 # Disconnect approximately 2*15=30 seconds after a network failure
140 "ServerAliveCountMax=1"
141 "ServerAliveInterval=15"
148 device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@aubergine.sp:/";
153 device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@losurdo.sp:/";
158 device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@mermet.sp:/";
163 "/mnt/ilico/severine" = {
164 device = "https://nuage.ilico.org/remote.php/dav/files/severine/";
168 conf = pkgs.writeText "davfs2.conf" ''
169 backup_dir /home/julm/.local/share/davfs2/ilico/severine
170 secrets /home/julm/.davfs2/secrets
182 "x-systemd.automount"
183 "x-systemd.device-timeout=1m"
184 "x-systemd.idle-timeout=1m"
185 "x-systemd.mount-timeout=10s"
193 defaultMode = "online";
196 localDiscovery = false;
198 Datastore.StorageMax = "10GB";
199 Discovery.MDNS.Enabled = false;
202 #Swarm.AddrFilters = null;
204 startWhenNeeded = true;
207 services.udev.packages = [
208 # Allow the console user access the Yubikey USB device node,
209 # needed for challenge/response to work correctly.
210 pkgs.yubikey-personalization
215 layout = "fr,us(altgr-intl)";
219 # Let the session be generated by home-manager
221 name = "home-manager";
223 ${pkgs.runtimeShell} $HOME/.hm-xsession &
231 services.displayManager = {
232 defaultSession = "home-manager";
233 #defaultSession = "none+xmonad";
234 #defaultSession = "mate";
235 #defaultSession = "cinnamon";
237 user = config.users.users.julm.name;
241 # This value determines the NixOS release with which your system is to be
242 # compatible, in order to avoid breaking some software such as database
243 # servers. You should change this only after NixOS release notes say you should.
244 system.stateVersion = "24.11"; # Did you read the comment?