1 { pkgs, lib, config, ... }:
6 md-toc = "grep '^#\\+' --color";
8 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
12 # Disable ctrl-s/ctrl-q flow control
16 programs.direnv.enableBashIntegration = true;
17 home.sessionVariables = {
18 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
20 home.file.".inputrc".text = ''
21 "\e[1~": beginning-of-line
23 "\e[7~": beginning-of-line
25 "\eOH": beginning-of-line
27 "\e[H": beginning-of-line
29 "\e[1;5C": forward-word
30 "\e[1;5D": backward-word
32 "\e[5D": backward-word
33 "\e\e[C": forward-word
34 "\e\e[D": backward-word