]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/oignon.nix
oignon: sshfs: add /mnt/mermet
[julm/julm-nix.git] / hosts / oignon.nix
1 { config, pkgs, lib, private, hostName, ... }:
2 {
3 imports = [
4 ../nixos/profiles/dnscrypt-proxy2.nix
5 ../nixos/profiles/graphical.nix
6 ../nixos/profiles/lang-fr.nix
7 ../nixos/profiles/networking.nix
8 ../nixos/profiles/printing.nix
9 ../nixos/profiles/security.nix
10 ../nixos/profiles/system.nix
11 ../nixos/profiles/tor.nix
12 ../nixos/profiles/wireguard/wg-intra.nix
13 oignon/backup.nix
14 oignon/hardware.nix
15 oignon/wireguard.nix
16 ];
17
18 home-manager.users.julm = {
19 imports = [ ../homes/julm.nix ];
20 host.hardware = [ "ThinkPad" "X201" ];
21 };
22 systemd.services.home-manager-julm.postStart = ''
23 ${pkgs.nix}/bin/nix-env --delete-generations +1 --profile /nix/var/nix/profiles/per-user/julm/home-manager
24 '';
25 users.users.julm = {
26 isNormalUser = true;
27 uid = 1000;
28 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
29 # which is already world readable.
30 hashedPassword = lib.readFile ../private/world/julm/hashedPassword;
31 extraGroups = [
32 "adbusers"
33 "lp"
34 "networkmanager"
35 "scanner"
36 "tor"
37 "video"
38 "wheel"
39 #"ipfs"
40 config.services.davfs2.davGroup
41 #"vboxusers"
42 ];
43 # If created, zfs-mount.service would require:
44 # zfs set overlay=yes ${hostName}/home
45 createHome = false;
46 openssh.authorizedKeys.keys = map lib.readFile [
47 ../private/shared/ssh/julm/losurdo.pub
48 ];
49 };
50
51 nix = {
52 extraOptions = ''
53 secret-key-files = ${private}/${hostName}/nix/binary-cache/priv.pem
54 '';
55 trustedUsers = [ config.users.users."julm".name ];
56 binaryCaches = [
57 #"http://nix-localcache.losurdo.wg"
58 "ssh://nix-ssh@losurdo.wg?priority=30"
59 ];
60 binaryCachePublicKeys = map lib.readFile [
61 ../private/shared/nix/losurdo.pub
62 ];
63 };
64 #environment.etc."nixpkgs".source = pkgs.path;
65 #environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
66
67 nix.allowedUsers = [ config.users.users."nix-ssh".name ];
68 nix.sshServe = {
69 enable = true;
70 keys = map lib.readFile [
71 ../private/shared/ssh/julm/losurdo.pub
72 ../private/shared/ssh/sevy/patate.pub
73 ../private/shared/ssh/julm/oignon.pub
74 ];
75 };
76
77 environment.systemPackages = [
78 pkgs.riseup-vpn # Can't be installed by home-manager because it needs to install policy-kit rules
79 ];
80
81 boot.extraModulePackages = [
82 #config.boot.kernelPackages.v4l2loopback
83 ];
84
85 programs.fuse.userAllowOther = true;
86
87 fileSystems =
88 # Use the user's gpg-agent session to query
89 # for the password of the SSH key when auto-mounting.
90 let
91 sshAsUser = user:
92 pkgs.writeScript "sshAsUser-${user}" ''
93 exec ${pkgs.sudo}/bin/sudo -i -u ${user} \
94 ${pkgs.openssh}/bin/ssh "$@"
95 '';
96 options =
97 [
98 "noatime" "noexec" "nosuid"
99 "user" "uid=julm" "gid=users" "allow_other"
100 "_netdev" "ssh_command=${sshAsUser "julm"}" # "reconnect"
101 "noauto" "x-gvfs-hide" "x-systemd.automount"
102 #"Compression=yes" # YMMV
103 # Disconnect approximately 2*15=30 seconds after a network failure
104 "ServerAliveCountMax=1"
105 "ServerAliveInterval=15"
106 ];
107 in {
108 "/mnt/losurdo" = {
109 device = "${pkgs.sshfsFuse}/bin/sshfs#julm@losurdo.wg:/";
110 fsType = "fuse";
111 inherit options;
112 };
113 "/mnt/mermet" = {
114 device = "${pkgs.sshfsFuse}/bin/sshfs#julm@mermet.wg:/";
115 fsType = "fuse";
116 inherit options;
117 };
118 };
119
120 networking.firewall.extraCommands = ''
121 ip46tables -A nixos-fw -i wg-intra -p tcp -m tcp --dport 8000 -j ACCEPT
122 '';
123
124 services.ipfs = {
125 #enable = true;
126 defaultMode = "online";
127 autoMount = true;
128 enableGC = true;
129 localDiscovery = false;
130 extraConfig = {
131 Datastore.StorageMax = "10GB";
132 Discovery.MDNS.Enabled = false;
133 #Bootstrap = [
134 #];
135 #Swarm.AddrFilters = null;
136 };
137 startWhenNeeded = true;
138 };
139
140 services.udev.packages = [
141 # Allow the console user access the Yubikey USB device node,
142 # needed for challenge/response to work correctly.
143 pkgs.yubikey-personalization
144 ];
145
146 services.xserver = {
147 desktopManager = {
148 session = [
149 # Let the session be generated by home-manager
150 { name = "home-manager";
151 start = ''
152 ${pkgs.runtimeShell} $HOME/.hm-xsession &
153 waitPID=$!
154 '';
155 }
156 ];
157 };
158 displayManager = {
159 defaultSession = "home-manager";
160 #defaultSession = "none+xmonad";
161 #defaultSession = "mate";
162 #defaultSession = "cinnamon";
163 autoLogin = {
164 user = config.users.users.julm.name;
165 };
166 };
167 };
168
169 # This value determines the NixOS release with which your system is to be
170 # compatible, in order to avoid breaking some software such as database
171 # servers. You should change this only after NixOS release notes say you should.
172 system.stateVersion = "20.09"; # Did you read the comment?
173 }