10 enableBashIntegration = config.programs.bash.enable;
11 # DOC: https://starship.rs/config/
14 command_timeout = 100;
15 continuation_prompt = "[↳](bright-black) ";
16 format = "$username$hostname$localip$shlvl$git_branch$git_commit$git_state$git_metrics$git_status$c$container$ocaml$purescript$nix_shell$haskell$memory_usage$sudo$cmd_duration$time$line_break$jobs$battery$directory$status$character";
21 format = "[$symbol$percentage]($style) ";
22 charging_symbol = " ";
23 discharging_symbol = " ";
26 unknown_symbol = " ";
37 vicmd_symbol = "[❮](bold green)";
39 success_symbol = "[➜](bold green)";
40 error_symbol = "[✗](bold red)";
44 format = "[($duration )]($style)";
45 style = "bright-black bold";
46 show_milliseconds = false;
48 show_notifications = false;
49 min_time_to_notify = 45000;
52 format = "[$symbol [$name]]($style) ";
54 style = "red bold dimmed";
59 fish_style_pwd_dir_length = 0;
60 format = "[$path]($style)[$read_only]($read_only_style) ";
62 #before_repo_root_style = "bold gray";
63 #repo_root_style = "bold cyan";
65 #read_only_style = "orange";
66 #repo_root_format = "[$before_root_path]($style)[$repo_root]($repo_root_style)[$path]($style)[$read_only]($read_only_style) ";
68 truncate_to_repo = true;
69 truncation_length = 3;
70 truncation_symbol = "…/";
71 use_logical_path = true;
72 use_os_path_sep = true;
74 directory.substitutions = {
75 ## Here is how you can shorten some long paths by text replacement;
76 ## similar to mapped_locations in Oh My Posh:;
81 ## Keep in mind that the order matters. For example:;
82 ## "Important Documents" = " ";
83 ## will not be replaced, because "Documents" was already substituted before.;
84 ## So either put "Important Documents" before "Documents" or use the substituted version:;
85 ## "Important " = " ";
86 #"Important " = " ";
90 format = "[$symbol($env_value )]($style)";
91 style = "bright-black bold italic dimmed";
95 default = "unknown shell";
98 format = "[$symbol($env_value )]($style)";
99 style = "bright-black bold italic dimmed";
102 default = "unknown user";
105 style = "bold black";
110 format = "[$symbol$branch(:$remote_branch)]($style) ";
112 style = "bold purple bg:0xFCA17D";
113 truncation_length = 9223372036854775807;
114 truncation_symbol = "…";
115 only_attached = false;
116 always_show_remote = false;
117 ignore_branches = [ ];
121 commit_hash_length = 7;
122 format = "[($hash$tag)]($style) ";
123 style = "green bold";
124 only_detached = true;
130 added_style = "bold green";
131 deleted_style = "bold red";
132 only_nonzero_diffs = true;
133 format = "([+$added]($added_style) )([-$deleted]($deleted_style) )";
138 am_or_rebase = "AM/REBASE";
139 bisect = "BISECTING";
140 cherry_pick = "🍒PICKING(bold red)";
142 format = "([$state( $progress_current/$progress_total)]($style)) ";
145 revert = "REVERTING";
146 style = "bold yellow";
149 format = "([$all_status( $ahead_behind)]($style) )";
150 style = "purple bold";
151 ahead = "⇡\${count}";
152 diverged = "⇡\${ahead_count}⇣\${behind_count}";
153 behind = "⇣\${count}";
161 format = "([$all_status$ahead_behind]($style) )";
162 ignore_submodules = false;
165 staged = "[++($count)](green)";
167 style = "red bold bg:0xFCA17D";
173 format = "[$symbol($version )]($style)";
174 version_format = "v$raw";
176 style = "yellow bold";
178 detect_extensions = [
188 detect_folders = [ ];
192 format = "[$hostname]($style) ";
194 style = "red dimmed bold";
199 symbol_threshold = 1;
200 number_threshold = 1;
201 format = "[$symbol$number]($style) ";
203 style = "yellow bold";
211 format = "[@$localipv4]($style) ";
213 style = "yellow bold";
217 format = "$symbol[$ram( | $swap)]($style) ";
218 style = "white bold dimmed";
224 format = "[$symbol]($style) ";
225 #format = "[$symbol$state( \\($name\\))]($style)";
228 #impure_msg = "[impure](bold red)";
229 pure_msg = "[pure](bold green)";
235 format = "[$symbol($version )(($switch_indicator$switch_name) )]($style)";
236 global_switch_indicator = "";
237 local_switch_indicator = "*";
238 style = "bold yellow";
240 version_format = "v$raw";
242 detect_extensions = [
262 format = "[$symbol($version )]($style)";
263 version_format = "v$raw";
265 style = "bold white";
267 detect_extensions = [ "purs" ];
268 detect_files = [ "spago.dhall" ];
269 detect_folders = [ ];
272 format = "[$symbol($version )]($style)";
273 version_format = "v$raw";
277 detect_extensions = [
284 detect_files = [ ".Rprofile" ];
285 detect_folders = [ ".Rproj.user" ];
289 format = "[$symbol$shlvl]($style) ";
292 style = "bold yellow";
296 format = "[$symbol$status]($style) ";
298 not_executable_symbol = "🚫";
299 not_found_symbol = "🔍";
301 pipestatus_format = "[$pipestatus] => [$symbol$common_meaning$signal_name$maybe_int]($style)";
302 pipestatus_separator = "|";
303 recognize_signal_code = true;
305 style = "bold red bg:blue";
306 success_symbol = "🟢 SUCCESS";
311 format = "[as $symbol]($style)";
314 allow_windows = false;
318 format = "[\\[$time\\]]($style)";
319 style = "bright-black bold";
322 utc_time_offset = "local";
323 # time_format = "%R"; # Hour:Minute Format;
324 time_format = "%T"; # Hour:Minute:Seconds Format;
328 format = "[$user]($style) ";
330 style_root = "red bold bg:0x9A348E";
331 style_user = "bright-black bold bg:0x9A348E";
339 function set_win_title(){
340 echo -ne "\033]0;Term: $USER@$HOSTNAME: $PWD\007"
342 starship_precmd_user_func="set_win_title"