]> Git — Sourcephile - julm/julm-nix.git/blob - homes/mo.nix
xmonad: rofi: import more environment variables
[julm/julm-nix.git] / homes / mo.nix
1 {
2 pkgs,
3 lib,
4 config,
5 hostName,
6 ...
7 }:
8 {
9 imports = [
10 ../home-manager/profiles/essential.nix
11 ../home-manager/profiles/vim.nix
12 ../home-manager/options.nix
13 (import (mo/hosts + "/${hostName}.nix"))
14 ];
15 programs.firefox.profiles =
16 let
17 defaultProfile = {
18 settings = {
19 "browser.bookmarks.showMobileBookmarks" = true;
20 "browser.compactmode.show" = true;
21 "browser.search.isUS" = false;
22 "browser.search.region" = "FR";
23 "distribution.searchplugins.defaultLocale" = "fr-FR";
24 "dom.security.https_first" = true;
25 "dom.security.https_only_mode" = true;
26 "general.useragent.locale" = "fr-FR";
27 "privacy.globalprivacycontrol.enabled" = true;
28 "privacy.globalprivacycontrol.functionality.enabled" = true;
29 "security.identityblock.show_extended_validation" = true;
30 "toolkit.legacyUserProfileCustomizations.stylesheets" = true;
31 #"privacy.firstparty.isolate" = true;
32 };
33 userChrome = lib.readFile ../home-manager/profiles/firefox/userChrome.css;
34 };
35 in
36 {
37 "646f487e.default" = lib.mkMerge [
38 defaultProfile
39 {
40 id = 0;
41 name = "default";
42 settings = {
43 "browser.startup.homepage" = "https://google.fr";
44 };
45 }
46 ];
47 };
48 }