11 #../nixos/profiles/debug.nix
12 ../nixos/profiles/graphical.nix
13 #../nixos/profiles/irssi.nix
14 ../nixos/profiles/lang-fr.nix
15 ../nixos/profiles/desktop.nix
16 ../nixos/profiles/printing.nix
17 #../nixos/profiles/radio.nix
18 ../nixos/profiles/tor.nix
19 ../nixos/profiles/bluetooth.nix
20 ../nixos/profiles/home.nix
21 #blackberry/backup.nix
22 blackberry/hardware.nix
24 blackberry/networking.nix
25 #blackberry/pixiecore.nix
26 blackberry/nix-ssh.nix
29 # Lower kernel's security for better performances
30 security.kernel.mitigations = "off";
32 home-manager.users.julm = {
33 imports = [ ../homes/julm.nix ];
36 openssh.authorizedKeys.keys = map lib.readFile [
37 # For nix -L run .#pumpkin.switch
38 ../users/julm/ssh/oignon.pub
39 ../users/julm/ssh/pumpkin.pub
40 ../users/julm/ssh/blackberry.pub
46 # Put the hashedPassword in /nix/store,
47 # though /etc/shadow is not world readable...
48 # printf %s $(mkpasswd -m md5crypt)
49 hashedPassword = lib.readFile blackberry/users/julm/login/hashedPassword.clear;
55 "plugdev" # For rtl-sdr
62 config.services.davfs2.davGroup
65 # If created, zfs-mount.service would require:
66 # zfs set overlay=yes ${hostName}/home
68 openssh.authorizedKeys.keys = map lib.readFile [
69 ../users/julm/ssh/oignon.pub
70 ../users/julm/ssh/pumpkin.pub
71 ../users/julm/ssh/losurdo.pub
80 trusted-public-keys = map lib.readFile [
83 nixPath = lib.mkForce [ "nixpkgs=${inputs.nixpkgs}" ];
86 environment.systemPackages = [
87 #pkgs.riseup-vpn # Can't be installed by home-manager because it needs to install policy-kit rules
90 boot.extraModulePackages = [
91 #config.boot.kernelPackages.v4l2loopback
94 programs.fuse.userAllowOther = true;
96 systemd.automounts = [
98 where = "/mnt/aubergine";
99 automountConfig.TimeoutIdleSec = "5 min";
104 # Use the user's gpg-agent session to query
105 # for the password of the SSH key when auto-mounting.
106 sshAsUser = pkgs.writeScript "sshAsUser" ''
108 exec ${pkgs.sudo}/bin/sudo -i -u "$user" \
109 ${pkgs.openssh}/bin/ssh "$@"
116 "exec" # Override "user"'s noexec
120 "ssh_command=${sshAsUser}\\040julm"
123 "x-systemd.automount"
124 #"Compression=yes" # YMMV
125 # Disconnect approximately 2*15=30 seconds after a network failure
126 "ServerAliveCountMax=1"
127 "ServerAliveInterval=15"
134 device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@aubergine.sp:/";
140 networking.firewall.extraCommands = ''
141 ip46tables -A nixos-fw -i wg-intra -p tcp -m tcp --dport 8000 -j ACCEPT
146 layout = "fr,us(altgr-intl)";
150 # Let the session be generated by home-manager
152 name = "home-manager";
154 ${pkgs.runtimeShell} $HOME/.hm-xsession &
162 services.displayManager = {
163 defaultSession = "home-manager";
164 #defaultSession = "none+xmonad";
165 #defaultSession = "mate";
166 #defaultSession = "cinnamon";
168 user = config.users.users.julm.name;
172 # This value determines the NixOS release with which your system is to be
173 # compatible, in order to avoid breaking some software such as database
174 # servers. You should change this only after NixOS release notes say you should.
175 system.stateVersion = "24.05"; # Did you read the comment?