11 ../../nixos/profiles/hardware/T480.nix
12 ../../nixos/profiles/zfs.nix
13 ../../nixos/profiles/zramSwap.nix
17 # Setting the machine-id avoids to reencrypt all credentials
18 # when reinstalling NixOS on a new drive.
19 # Manually generated with : uuidgen | tr -d -
20 environment.etc.machine-id.source = ./machine-id.clear;
22 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
23 # You should try to make this id unique among your hosts.
24 # Manually generated with : uuidgen | head -c8
25 networking.hostId = "e6eba6c4";
32 # Deprecated in nixos-24.11
33 #boot.kernelPackages = config.boot.zfs.package.latestCompatibleLinuxPackages;
36 canTouchEfiVariables = true;
37 efiSysMountPoint = "/boot1";
42 # Roughly 25MiB (initrd) + 9MiB (kernel) per configuration
43 configurationLimit = 6;
44 memtest86.enable = true;
46 extraInstallCommands = ''
48 cp -r /efiboot/efi1 /efiboot/efi2
51 # FIXME: needs https://github.com/NixOS/nixpkgs/pull/246897
55 boot.zfs.requestEncryptionCredentials = [ "${hostName}/root" ];
57 hardware.enableRedistributableFirmware = true;
59 services.udev.extraRules = ''
60 ACTION=="add", ATTRS{idVendor}=="5986", ATTRS{idProduct}=="1141", RUN="${pkgs.runtimeShell} -c 'echo 1 >/sys$devpath/remove'"
63 fileSystems."/boot1" = {
64 device = "/dev/disk/by-partlabel/${hostName}_ssd1_boot";
77 device = "/dev/disk/by-partlabel/${hostName}_ssd1_swap";
80 cipher = "aes-xts-plain64";
81 source = "/dev/urandom";
86 boot.supportedFilesystems = [
92 device = "${hostName}/root";
94 options = [ "zfsutil" ];
96 fileSystems."/nix" = {
97 device = "${hostName}/root/nix";
104 fileSystems."/var" = {
105 device = "${hostName}/root/var";
113 services.pipewire.jack.enable = true;