1 { pkgs, lib, config, ... }:
4 ../../../home-manager/profiles/chat.nix
5 ../../../home-manager/profiles/developing.nix
6 ../../../home-manager/profiles/direnv.nix
7 ../../../home-manager/profiles/drawing.nix
8 ../../../home-manager/profiles/gaming.nix
9 ../../../home-manager/profiles/git.nix
10 ../../../home-manager/profiles/gnupg.nix
11 ../../../home-manager/profiles/graphical.nix
12 ../../../home-manager/profiles/lf.nix
13 ../../../home-manager/profiles/mpv.nix
14 ../../../home-manager/profiles/networking.nix
15 ../../../home-manager/profiles/nix.nix
16 ../../../home-manager/profiles/radio.nix
17 ../../../home-manager/profiles/science.nix
18 ../../../home-manager/profiles/video.nix
19 ../../../home-manager/profiles/wireless.nix
20 ../../../home-manager/profiles/yt-dlp.nix
22 ../../../home-manager/profiles/emacs.nix
23 ../../../home-manager/profiles/firefox.nix
24 ../../../home-manager/profiles/ghc.nix
25 ../../../home-manager/profiles/starship.nix
26 ../../../home-manager/profiles/xmonad.nix
27 ../../../home-manager/profiles/arbtt.nix
31 programs.bash.shellAliases.riseup = "sudo ip netns exec riseup sudo -u $USER PULSE_SERVER=/run/user/$(id -u $USER)/pulse/native";
32 programs.gpg.homedir = "${config.home.homeDirectory}/files/sec/.gnupg";
33 home.sessionVariables = {
34 PASSWORD_STORE_DIR = "$HOME/files/sec/.password-store";
47 # psnup conflicts with pkgs.texlive.combined.scheme-*
48 (lib.lowPrio pkgs.psutils)
63 pkgs.transmission-remote-gtk
70 #(pkgs.qgis.override { extraPythonPackages = (ps: [
71 # ps.pyqt5_with_qtwebkit
91 xdg.dataFile."arbtt/categorize.cfg".text = ''
92 $idle > 30 ==> tag inactive,
94 current window $program = ["evince", "Evince"] && current window $title =~ m!(.*) — (.*)!
96 current window $program = ["gl", "mpv"] && current window $title =~ m!MPV: playing: ([^:]*)!
98 current window $program = ["Navigator"] && current window $title =~ m!Web: ([^:]*): ([^:]*)!
100 current window $title =~ m!Term: ([^:]*): (?:~|/home/julm)/(?:src|work)/(.*)!
102 current window $title =~ m!Term: ([^:]*): (?:~|/home/julm)/(?:files)/(.*)!
105 tag Desktop:$current.desktop,
106 tag Program:$current.program,
109 /* Cannot be automounted
110 systemd.user.mounts = {
114 "network-online.target"
115 "wireguard-wg-intra.target"
118 "network-online.target"
119 "wireguard-wg-intra.target"
123 WantedBy = ["default.target"];
126 What = "julm@aubergine.sp:/";
127 Where = "/mnt/aubergine";
129 Options = lib.concatStringsSep "," [
134 "exec" # Override "user"'s noexec
141 # Does not work for user mounts
142 #"x-systemd.automount"
143 "IdentityFile=/home/julm/.ssh/id_ed25519"
144 #"Compression=yes" # YMMV
145 # Disconnect approximately 2*15=30 seconds after a network failure
146 "ServerAliveCountMax=1"
147 "ServerAliveInterval=15"
154 Automounting does not work without root privileges
155 systemd.user.automounts = {
158 WantedBy = ["user.target"];
163 Where = "/mnt/aubergine";
164 TimeoutIdleSec = "5 min";