]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/minimal.nix
pumpkin: add host
[julm/julm-nix.git] / hosts / minimal.nix
1 # Usage:
2 # nix -L build .#nixosConfigurations.minimal.config.system.build.isoImage
3 # sudo dd if=result/iso/nixos-24.11-patch-75f694f-x86_64-linux.iso of=/dev/disk/by-id/usb-Generic_Mass-Storage-0\:0 status=progress bs=4M
4 # sync
5 { pkgs, lib, config, inputs, hosts, modulesPath, ... }:
6 {
7 imports = [
8 (modulesPath + "/installer/cd-dvd/installation-cd-minimal.nix")
9 ];
10
11 # Lower kernel's security for better performances
12 security.kernel.mitigations = "off";
13
14 nixpkgs.hostPlatform = {
15 system = "x86_64-linux";
16 config = "x86_64-unknown-linux-gnu";
17 };
18
19 ## Some useful options for setting up a new system
20 services.getty.autologinUser = lib.mkForce "root";
21 users.users.root.openssh.authorizedKeys.keys =
22 hosts.blackberry.config.users.users.julm.openssh.authorizedKeys.keys;
23 #console.keyMap = "de";
24 # hardware.video.hidpi.enable = true;
25
26 # Faster
27 isoImage.squashfsCompression = lib.mkDefault "gzip -Xcompression-level 1";
28
29 system.stateVersion = config.system.nixos.release;
30
31 documentation = {
32 enable = false;
33 doc.enable = false;
34 };
35
36 }