1 { pkgs, config, hostName, inputs, ... }:
4 ../../nixos/profiles/hardware/T14sAMDGen1.nix
5 ../../nixos/profiles/zfs.nix
6 #../../nixos/profiles/zramSwap.nix
9 # Setting the machine-id avoids to reencrypt all credentials
10 # when reinstalling NixOS on a new drive.
11 # Manually generated with : uuidgen | tr -d -
12 environment.etc.machine-id.source = ./machine-id.clear;
14 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
15 # You should try to make this id unique among your hosts.
16 # Manually generated with : uuidgen | head -c8
17 networking.hostId = "d70732b9";
25 # Deprecated in nixos-24.11
26 #boot.kernelPackages = config.boot.zfs.package.latestCompatibleLinuxPackages;
29 canTouchEfiVariables = true;
30 efiSysMountPoint = "/boot1";
35 # Roughly 25MiB (initrd) + 9MiB (kernel) per configuration
36 configurationLimit = 6;
37 memtest86.enable = true;
39 extraInstallCommands = ''
41 cp -r /efiboot/efi1 /efiboot/efi2
44 # FIXME: needs https://github.com/NixOS/nixpkgs/pull/246897
48 boot.zfs.requestEncryptionCredentials = [ "${hostName}/root" ];
50 #console.keyMap = lib.mkForce "de";
52 hardware.enableRedistributableFirmware = true;
54 fileSystems."/boot1" =
56 device = "/dev/disk/by-partlabel/${hostName}_nvme1_boot";
58 options = [ "rw" "noexec" "nodev" "nofail" "X-mount.mkdir" "iocharset=iso8859-1" ];
62 device = "/dev/disk/by-partlabel/${hostName}_nvme1_swap";
65 cipher = "aes-xts-plain64";
66 source = "/dev/urandom";
71 boot.supportedFilesystems = [ "ntfs" "vfat" ];
75 device = "${hostName}/root";
77 options = [ "zfsutil" ];
81 device = "${hostName}/root/nix";
83 options = [ "X-mount.mkdir" "zfsutil" ];
87 device = "${hostName}/root/var";
89 options = [ "X-mount.mkdir" "zfsutil" ];
92 services.pipewire.jack.enable = true;
95 # Suspending not work well on this old computer.
96 #lidEventCommands = "";