1 { pkgs, lib, config, inputs, hostName, ... }:
3 domain = "sourcephile.fr";
4 iface = config.services.nebula.networks.${domain}.tun.device;
8 ../../domains/sourcephile.fr/nebula.nix
10 services.nebula.networks.${domain} = {
14 { port = "any"; proto = "any"; groups = [ "sourcephile" "intra" ]; }
17 { port = "any"; proto = "any"; host = "any"; }
27 networking.nftables.ruleset = ''
29 chain input-${iface} {
30 tcp dport ipp counter accept comment "cupsd: IPP"
31 tcp dport sane-port counter accept comment "saned: control port"
32 # NoticeNote: not actually useful because there is a rule `ct related accept` before
33 ct helper "sane" counter accept comment "saned: data ports"