]> Git — Sourcephile - julm/julm-nix.git/blob - nixos/profiles/hardware/X200.nix
tlp: enable on all hardwares
[julm/julm-nix.git] / nixos / profiles / hardware / X200.nix
1 { config, lib, pkgs, ... }:
2 {
3 imports = [
4 ./thinkpad.nix
5 ];
6
7 # tp_smapi works on ThinkPads made before 2013. See compat table:
8 # https://www.thinkwiki.org/wiki/Tp_smapi#Model-specific_status
9 boot.kernelModules = [ "tp_smapi" ];
10 boot.extraModulePackages = with config.boot.kernelPackages; [ tp_smapi ];
11 }