]> Git — Sourcephile - julm/julm-nix.git/blob - homes/softwares/urxvt.nix
merge home-manager config
[julm/julm-nix.git] / homes / softwares / urxvt.nix
1 {
2 home.file.".Xresources".text = ''
3 URxvt*termName: rxvt
4 URxvt*letterSpace: 0
5 URxvt*lineSpace: 0
6 URxvt*font:xft:DejaVu Sans Mono:size=7.38
7 URxvt*buffered: true
8 URxvt*depth: 32
9 URxvt*background: black
10 URxvt*cursorBlink: on
11 URxvt*cursorColor2: black
12 URxvt*cursorColor: #00B10B
13 URxvt*fading: 0
14 URxvt*foreground: white
15 URxvt*geometry: 61x20
16 URxvt*highlightColor: red
17 URxvt*insecure: True
18 URxvt*internalBorder: 2
19 URxvt*jumpScroll: on
20 URxvt*keysym.C-ISO_Left_Tab: \033[27;6;9~
21 URxvt*keysym.C-Tab: \033[27;5;9~
22 URxvt*keysym.KP_End: \033[4~
23 URxvt*keysym.KP_Enter: \n
24 URxvt*keysym.KP_Home: \033[1~
25 URxvt*meta8: False
26 URxvt*pointerColor2: black
27 URxvt*pointerColor: green
28 URxvt*reverseVideo: false
29 URxvt*saveLines: 0
30 URxvt*scrollBar_floating: on
31 URxvt*scrollBar_right: on
32 URxvt*scrollColor: grey20
33 URxvt*scrollTtyKeypress: on
34 URxvt*scrollTtyOutput: off
35 URxvt*scrollWithBuffer: on
36 URxvt*scrollbar*foreground: blue
37 URxvt*scrollstyle: plain
38 URxvt*troughColor: blue
39 URxvt*visualBell: off
40 URxvt.font-size.step: 1
41 URxvt.iso14755_52: False
42 URxvt.keysym.C-Down: perl:font-size:decrease
43 URxvt.keysym.C-S-Down: perl:font-size:decglobal
44 URxvt.keysym.C-S-Up: perl:font-size:incglobal
45 URxvt.keysym.C-Up: perl:font-size:increase
46 URxvt.perl-ext-common: default,font-size
47 URxvt.urgentOnBell: true
48
49 !URxvt.urlLauncher: elinks
50 !URxvt*font: xft:DejaVu Sans Mono:pixelsize=9:antialias=true
51 !URxvt*font: xft:DejaVu Sans Mono:size=6.38:weight=medium:antialias=true:hintstyle=100:autohint=0,xft:unifont,xft:freemono:pixelsize=13,xft:Code2000:antialias=false
52 !URxvt*font: xft:DejaVu Sans Mono:pixelsize=24
53 !URxvt*font: xft:Inconsolata:pixelsize=10
54 !URxvt*font: xft:Fira Code:pixelsize=10
55 !URxvt*scrollWithBuffer: true
56 !: hinting=true:slant=0:weight=50
57 !URxvt*boldFont: xft:DejaVu Sans Mono:bold:pixelsize=9:antialias=true:hinting=true
58 !urxvt*boldColors: on
59 ! Allow switching of font sizes
60 !URxvt.keysym.C-M-minus: command:\033]710;xft:Terminus-8:slant=0:weight=80,xft:DejaVu\ Sans\ Mono-9:slant=0:weight=80,xft:Inconsolata-10,x:-schumacher-clean-medium-r-normal-*-12-*-*-*-c-*-iso10646-1,x:-misc-fixed-medium-r-semicondensed-*-13-*-*-*-c-*-iso10646-1,x:-b&h-lucidatypewriter-medium-r-normal-*-12-*-*-*-m-*-iso10646-1\007\033]711;xft:Terminus-8:slant=0:weight=200,xft:DejaVu\ Sans\ Mono-9:slant=0:weight=200,x:-misc-fixed-bold-r-semicondensed-*-13-*-*-*-c-*-iso10646-1,x:-b&h-lucidatypewriter-bold-r-normal-*-12-*-*-*-m-*-iso10646-1\007\033]712;xft:Terminus-8:slant=110:weight=80,xft:DejaVu Sans Mono-8:slant=110:weight=80\007\033]713;xft:Terminus-8:slant=110:weight=200,xft:DejaVu Sans Mono-8:slant=110:weight=200\007
61 !URxvt.keysym.C-M-equal: command:\033]710;xft:Terminus-14:slant=0:weight=80,xft:DejaVu\ Sans\ Mono-14:slant=0:weight=80,xft:Inconsolata-16,x:-gnu-unifont-medium-r-normal-*-17-*-*-*-c-*-iso10646-1,x:-b&h-lucidatypewriter-medium-r-normal-*-17-*-*-*-m-*-iso10646-1\007\033]711;xft:Terminus-14:slant=0:weight=200,xft:DejaVu\ Sans\ Mono-14:slant=0:weight=200,x:-misc-fixed-medium-r-normal-*-20-*-*-*-c-*-iso10646-1,x:-b&h-lucidatypewriter-*-r-normal-*-17-*-*-*-m-*-iso10646-1\007\033]712;xft:Terminus-14:slant=110:weight=80,xft:DejaVu Sans Mono-14:slant=110:weigth=80\007\033]713;xft:Terminus-14:slant=110:weight=200,xft:DejaVu Sans Mono-14:slant=110:weight=200\007
62 !URxvt.iso14755: False
63 !URxvt.perl-ext-common: default,matcher
64 '';
65 }