]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/aubergine/hardware.nix
hardware: add T480
[julm/julm-nix.git] / hosts / aubergine / hardware.nix
1 { pkgs, lib, hostName, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/hardware/apu6b4.nix
5 ../../nixos/profiles/hardware/ME909u-521.nix
6 ../../nixos/profiles/serial.nix
7 ../../nixos/profiles/zfs.nix
8 ../../nixos/profiles/zramSwap.nix
9 ];
10
11 # Setting the machine-id avoids to reencrypt all credentials
12 # when reinstalling NixOS on a new drive.
13 # Manually generated with : uuidgen | tr -d -
14 environment.etc.machine-id.source = ./machine-id.clear;
15
16 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
17 # You should try to make this id unique among your hosts.
18 # Manually generated with : uuidgen | head -c8
19 networking.hostId = "408a404a";
20
21 /*
22 boot.loader.efi = {
23 canTouchEfiVariables = true;
24 efiSysMountPoint = "/boot/efi";
25 };
26 */
27 boot.loader.grub = {
28 enable = true;
29 devices = [
30 #"/dev/disk/by-id/mmc-SU08G_0xb0320f0f"
31 #"/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
32 "/dev/disk/by-id/ata-YMTC_JGS_2201060101833"
33 ];
34 configurationLimit = 9;
35
36 #zfsSupport = true;
37 #efiSupport = true;
38 #enableCryptodisk = true;
39 };
40 boot.tmp.useTmpfs = true;
41 #boot.kernelPackages = pkgs.linuxKernel.packages.linux_4_14;
42
43 boot.supportedFilesystems = [ /*"ntfs"*/ "vfat" ];
44 boot.extraModulePackages = [
45 #config.boot.kernelPackages.exfat-nofuse
46 ];
47
48 hardware.enableRedistributableFirmware = true;
49
50 powerManagement.powertop.enable = true;
51
52 #services.fprintd.enable = true;
53
54 fileSystems."/" =
55 {
56 device = "${hostName}/root";
57 fsType = "zfs";
58 };
59 fileSystems."/boot" =
60 {
61 device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
62 fsType = "ext4";
63 };
64 fileSystems."/boot/efi" =
65 {
66 device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
67 fsType = "vfat";
68 };
69 fileSystems."/nix" =
70 {
71 device = "${hostName}/nix";
72 fsType = "zfs";
73 };
74 fileSystems."/var" =
75 {
76 device = "${hostName}/var";
77 fsType = "zfs";
78 };
79 fileSystems."/home" =
80 {
81 device = "${hostName}/home";
82 fsType = "zfs";
83 };
84 swapDevices =
85 [
86 {
87 device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
88 randomEncryption = {
89 enable = true;
90 cipher = "aes-xts-plain64";
91 source = "/dev/urandom";
92 };
93 }
94 ];
95
96 hardware.pulseaudio.enable = lib.mkDefault true;
97 #hardware.pulseaudio.tcp.enable = lib.mkDefault true;
98
99 }