]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/courge/backup.nix
courge: sanoid: tweaks
[julm/julm-nix.git] / hosts / courge / backup.nix
1 { pkgs, lib, hostName, ... }:
2 with builtins;
3 {
4 services.sanoid = {
5 enable = true;
6 extraArgs = [ "--verbose" ];
7 datasets = {
8 "${hostName}/root/home/mo" = {
9 autosnap = true;
10 autoprune = true;
11 hourly = 0;
12 daily = 15;
13 monthly = 0;
14 yearly = 0;
15 recursive = true;
16 };
17 "${hostName}/root/home/mo/.cache" = {
18 autosnap = false;
19 };
20 "${hostName}/root/home/mo/.mozilla" = {
21 autosnap = true;
22 autoprune = true;
23 daily = 3;
24 };
25 "${hostName}/root/home/mo/.thunderbird" = {
26 autosnap = true;
27 autoprune = true;
28 hourly = 12;
29 daily = 7;
30 };
31 "${hostName}/root/home/mo/Documents" = {
32 autosnap = true;
33 autoprune = true;
34 hourly = 12;
35 daily = 31;
36 };
37 "${hostName}/root/home/mo/Telechargements" = {
38 autosnap = false;
39 };
40 };
41 };
42 }