4 ../../nixos/profiles/hardware/X200.nix
5 ../../nixos/profiles/zfs.nix
6 ../../nixos/profiles/zramSwap.nix
11 memtest86.enable = true;
13 device = "/dev/disk/by-id/ata-CT250MX500SSD1_2004E2849DD1";
14 configurationLimit = 3;
19 device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
22 fileSystems."/boot/efi" =
24 device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
29 device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
32 cipher = "aes-xts-plain64";
33 source = "/dev/urandom";
38 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
39 # You should try to make this id unique among your hosts.
40 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
41 networking.hostId = "ec2adb40";
43 boot.supportedFilesystems = [ "ntfs" "vfat" ];
44 boot.extraModulePackages = [
45 #config.boot.kernelPackages.exfat-nofuse
48 powerManagement.powertop.enable = true;
52 device = "${hostName}/root";
57 device = "${hostName}/nix";
60 fileSystems."/home/sevy" =
62 device = "${hostName}/home";
65 fileSystems."/home/sevy/Documents" =
67 device = "${hostName}/home/Documents";
70 fileSystems."/home/sevy/Images" =
72 device = "${hostName}/home/Images";
75 fileSystems."/home/sevy/Téléchargements" =
77 device = "${hostName}/home/Downloads";
80 fileSystems."/home/sevy/.thunderbird" =
82 device = "${hostName}/home/Mails";
85 fileSystems."/home/sevy/Vidéos" =
87 device = "${hostName}/home/Videos";
92 device = "${hostName}/var";
95 fileSystems."/var/cache" =
97 device = "${hostName}/var/cache";
100 fileSystems."/var/log" =
102 device = "${hostName}/var/log";
105 fileSystems."/var/tmp" =
107 device = "${hostName}/var/tmp";