1 { pkgs, hostName, ... }:
4 ../../nixos/profiles/hardware/E5500.nix
5 ../../nixos/profiles/zfs.nix
6 ../../nixos/profiles/zramSwap.nix
10 # Avoids huge slow downs, especially with nix.
11 "zfs.zfs_arc_max=${toString (1024 * 1024 * 1024)}" # bytes
14 # Setting the machine-id avoids to reencrypt all credentials
15 # when reinstalling NixOS on a new drive.
16 # Manually generated with : uuidgen | tr -d -
17 environment.etc.machine-id.source = ./machine-id.clear;
19 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
20 # You should try to make this id unique among your hosts.
21 # Manually generated with : uuidgen | head -c8
22 networking.hostId = "e53001b7";
27 memtest86.enable = true;
29 { path = "/boot1"; devices = [ "/dev/disk/by-id/ata-CT250MX500SSD1_2004E2849DD5" ]; }
31 # Roughly 25MiB (initrd) + 9MiB (kernel) per configuration
32 configurationLimit = 6;
36 #enableCryptodisk = true;
39 boot.zfs.requestEncryptionCredentials = [ "${hostName}/root" ];
41 hardware.enableRedistributableFirmware = true;
43 fileSystems."/boot1" =
45 device = "/dev/disk/by-partlabel/${hostName}_ssd1_boot";
47 options = [ "rw" "noexec" "nodev" "nofail" "X-mount.mkdir" "iocharset=iso8859-1" ];
51 device = "/dev/disk/by-partlabel/${hostName}_ssd1_swap";
54 cipher = "aes-xts-plain64";
55 source = "/dev/urandom";
60 boot.supportedFilesystems = [ "ntfs" "vfat" ];
64 device = "${hostName}/root";
66 options = [ "zfsutil" ];
70 device = "${hostName}/root/nix";
72 options = [ "X-mount.mkdir" "zfsutil" ];
76 device = "${hostName}/root/var";
78 options = [ "X-mount.mkdir" "zfsutil" ];
81 services.pipewire.jack.enable = true;