]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/yt-dlp.nix
yt-dlp: prefer 480p
[julm/julm-nix.git] / home-manager / profiles / yt-dlp.nix
1 { pkgs, lib, config, ... }:
2 {
3 imports = [
4 ./aria2c.nix
5 ];
6 home.packages = [ pkgs.yt-dlp ];
7 xdg.configFile."yt-dlp/config".text = ''
8 --download-archive .downloaded
9 --format ${lib.concatStringsSep "/" [
10 #"bestvideo[height=360][ext=mp4]+bestaudio"
11 "bestvideo[height=480][ext=mp4]+bestaudio"
12 #"best[height=360][ext=mp4]"
13 "best[height=480][ext=mp4]"
14 #"best[height=360]"
15 "best[height=480]"
16 "best"
17 ]}
18 --output "%(upload_date>%Y-%m-%d)s - %(title)s.%(id)s.%(format_id)s.%(ext)s"
19 --prefer-free-formats
20 '';
21 }