]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/yt-dlp.nix
yt-dlp: add phantomjs
[julm/julm-nix.git] / home-manager / profiles / yt-dlp.nix
1 { pkgs, lib, config, ... }:
2 {
3 imports = [
4 ./aria2c.nix
5 ];
6 home.packages = [
7 pkgs.phantomjs
8 pkgs.yt-dlp
9 ];
10 xdg.configFile."yt-dlp/config".text = ''
11 #--download-archive .downloaded
12 --format ${lib.concatStringsSep "/" [
13 #"bestvideo[height=360][ext=mp4]+bestaudio"
14 "bestvideo[height=480][ext=mp4]+bestaudio"
15 #"best[height=360][ext=mp4]"
16 "best[height=480][ext=mp4]"
17 #"best[height=360]"
18 "best[height=480]"
19 "best"
20 ]}
21 --output "%(upload_date>%Y-%m-%d)s - %(title)s.%(id)s.%(format_id)s.%(ext)s"
22 --prefer-free-formats
23 '';
24 }