]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/htop.nix
nix: strip down essential profile
[julm/julm-nix.git] / home-manager / profiles / htop.nix
1 { pkgs, lib, ... }:
2 {
3 # This must appear before "column_meters_*" options
4 xdg.configFile."htop/htoprc".text = lib.mkBefore ''
5 header_layout=two_50_50
6 '';
7 programs.htop = {
8 enable = lib.mkDefault true;
9 settings = {
10 account_guest_in_cpu_meter = false;
11 all_branches_collapsed = false;
12 color_scheme = false;
13 column_meter_modes_0 = "3 1 1 1";
14 column_meter_modes_1 = "2 2 2 3 1 3 1 1 1 1";
15 column_meters_0 = "AllCPUs Memory Swap Zram";
16 column_meters_1 = "Systemd LoadAverage Uptime DiskIO DiskIO NetworkIO NetworkIO ZFSARC ZFSCARC PressureStallIOFull";
17 cpu_count_from_one = false;
18 degree_fahrenheit = false;
19 delay = 15;
20 detailed_cpu_time = true;
21 enable_mouse = true;
22 find_comm_in_cmdline = true;
23 header_margin = true;
24 hide_function_bar = false;
25 hide_kernel_threads = false;
26 hide_threads = true;
27 hide_userland_threads = true;
28 highlight_base_name = true;
29 highlight_changes = true;
30 highlight_changes_delay_secs = 5;
31 highlight_deleted_exe = true;
32 highlight_megabytes = true;
33 highlight_threads = true;
34 screen_tabs = true;
35 shadow_other_users = false;
36 show_cpu_frequency = true;
37 show_cpu_temperature = false;
38 show_cpu_usage = true;
39 show_merged_command = false;
40 show_program_path = false;
41 show_thread_names = false;
42 sort_direction = 0;
43 sort_key = 46; # PERCENT_CPU
44 strip_exe_from_cmdline = true;
45 tree_sort_direction = 0;
46 tree_sort_key = 46; # PERCENT_CPU
47 tree_view = true;
48 tree_view_always_by_pid = false;
49 update_process_names = false;
50 /*
51 "screen:Main" = ''
52 PID USER PRIORITY NICE M_VIRT M_RESIDENT M_SHARE STATE PERCENT_CPU PERCENT_MEM TIME Command
53 .sort_key=PERCENT_CPU
54 .tree_sort_key=PERCENT_CPU
55 .tree_view=1
56 .tree_view_always_by_pid=0
57 .sort_direction=0
58 .tree_sort_direction=0
59 .all_branches_collapsed=0
60 '';
61 "screen:I/O" = ''
62 PID USER IO_PRIORITY IO_RATE IO_READ_RATE IO_WRITE_RATE
63 .sort_key=IO_RATE
64 .tree_sort_key=PID
65 .tree_view=0
66 .tree_view_always_by_pid=0
67 .sort_direction=-1
68 .tree_sort_direction=1
69 .all_branches_collapsed=0
70 '';
71 */
72 };
73 };
74 }