]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/oignon.nix
creds: improve a bit when reinstalling
[julm/julm-nix.git] / hosts / oignon.nix
1 { config, pkgs, lib, inputs, hostName, ... }:
2 {
3 imports = [
4 ../nixos/profiles/builder.nix
5 ../nixos/profiles/debug.nix
6 ../nixos/profiles/graphical.nix
7 ../nixos/profiles/lang-fr.nix
8 ../nixos/profiles/printing.nix
9 ../nixos/profiles/security.nix
10 ../nixos/profiles/system.nix
11 ../nixos/profiles/tor.nix
12 ../nixos/profiles/irssi.nix
13 oignon/backup.nix
14 oignon/hardware.nix
15 oignon/networking.nix
16 ];
17
18 # Lower kernel's security for better performances
19 boot.kernelParams = [ "mitigations=off" ];
20
21 home-manager.users.julm = {
22 imports = [ ../homes/julm.nix ];
23 };
24 systemd.services.home-manager-julm.postStart = ''
25 ${pkgs.nix}/bin/nix-env --delete-generations +1 --profile /nix/var/nix/profiles/per-user/julm/home-manager
26 '';
27 users.users.root = {
28 openssh.authorizedKeys.keys = map lib.readFile [
29 # For nix -L run .#oignon.switch
30 ../users/julm/ssh/oignon.pub
31 ];
32 };
33 users.users.julm = {
34 isNormalUser = true;
35 uid = 1000;
36 # Put the hashedPassword in /nix/store,
37 # though /etc/shadow is not world readable...
38 # printf %s $(mkpasswd -m md5crypt)
39 hashedPassword = lib.readFile oignon/users/julm/login/hashedPassword.clear;
40 extraGroups = [
41 "adbusers"
42 "dialout"
43 "lp"
44 "networkmanager"
45 "scanner"
46 "tor"
47 "video"
48 "wheel"
49 #"ipfs"
50 config.services.davfs2.davGroup
51 #"vboxusers"
52 ];
53 # If created, zfs-mount.service would require:
54 # zfs set overlay=yes ${hostName}/home
55 createHome = false;
56 openssh.authorizedKeys.keys = map lib.readFile [
57 ../users/julm/ssh/losurdo.pub
58 ];
59 };
60
61 systemd.services.nix-daemon.serviceConfig.LoadCredentialEncrypted =
62 [ ("${hostName}.key:" + inputs.self + "/hosts/${hostName}/nix/secret-key-files.priv.pem.cred") ];
63 nix = {
64 extraOptions = ''
65 secret-key-files = /run/credentials/nix-daemon.service/${hostName}.key
66 '';
67 settings = {
68 trusted-users = [ config.users.users."julm".name ];
69 substituters = [
70 #"http://nix-localcache.losurdo.wg"
71 "ssh://nix-ssh@losurdo.wg?priority=30"
72 ];
73 trusted-public-keys = map lib.readFile [
74 ../hosts/losurdo/nix/key.pub
75 ];
76 };
77 nixPath = lib.mkForce [ "nixpkgs=${inputs.nixpkgs}" ];
78 };
79 #environment.etc."nixpkgs".source = pkgs.path;
80 #environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
81
82 nix.settings.allowed-users = [ config.users.users."nix-ssh".name ];
83 nix.sshServe = {
84 enable = true;
85 keys = map lib.readFile [
86 ../users/julm/ssh/losurdo.pub
87 ../users/julm/ssh/oignon.pub
88 ../users/sevy/ssh/patate.pub
89 ];
90 };
91
92 # Setting the machine-id avoids to reencrypt all credentials
93 # when reinstalling NixOS on a new drive.
94 environment.etc.machine-id.source = oignon/machine-id;
95
96 environment.systemPackages = [
97 pkgs.riseup-vpn # Can't be installed by home-manager because it needs to install policy-kit rules
98 ];
99
100 boot.extraModulePackages = [
101 #config.boot.kernelPackages.v4l2loopback
102 ];
103
104 programs.fuse.userAllowOther = true;
105
106 services.davfs2.enable = true;
107
108 fileSystems =
109 # Use the user's gpg-agent session to query
110 # for the password of the SSH key when auto-mounting.
111 let
112 sshAsUser = user:
113 pkgs.writeScript "sshAsUser-${user}" ''
114 exec ${pkgs.sudo}/bin/sudo -i -u ${user} \
115 ${pkgs.openssh}/bin/ssh "$@"
116 '';
117 options =
118 [
119 "noatime" "noexec" "nosuid"
120 "user" "uid=julm" "gid=users" "allow_other"
121 "_netdev" "ssh_command=${sshAsUser "julm"}" # "reconnect"
122 "noauto" "x-gvfs-hide" "x-systemd.automount"
123 #"Compression=yes" # YMMV
124 # Disconnect approximately 2*15=30 seconds after a network failure
125 "ServerAliveCountMax=1"
126 "ServerAliveInterval=15"
127 ];
128 in {
129 "/mnt/aubergine" = {
130 device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@aubergine.wg:/";
131 fsType = "fuse";
132 inherit options;
133 };
134 "/mnt/losurdo" = {
135 device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@losurdo.wg:/";
136 fsType = "fuse";
137 inherit options;
138 };
139 "/mnt/mermet" = {
140 device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@mermet.wg:/";
141 fsType = "fuse";
142 inherit options;
143 };
144 "/mnt/ilico/severine" = {
145 device = "https://nuage.ilico.org/remote.php/dav/files/severine/";
146 fsType = "davfs";
147 options =
148 let conf = pkgs.writeText "davfs2.conf" ''
149 backup_dir /home/julm/.local/share/davfs2/ilico/severine
150 secrets /home/julm/.davfs2/secrets
151 ''; in
152 [ "conf=${conf}" "user" "noexec" "nosuid"
153 "noauto" "nofail" "_netdev" "reconnect"
154 "x-systemd.automount"
155 "x-systemd.device-timeout=1m"
156 "x-systemd.idle-timeout=1m"
157 "x-systemd.mount-timeout=10s"
158 ];
159 };
160 };
161
162 networking.firewall.extraCommands = ''
163 ip46tables -A nixos-fw -i wg-intra -p tcp -m tcp --dport 8000 -j ACCEPT
164 '';
165
166 services.kubo = {
167 #enable = true;
168 defaultMode = "online";
169 autoMount = true;
170 enableGC = true;
171 localDiscovery = false;
172 extraConfig = {
173 Datastore.StorageMax = "10GB";
174 Discovery.MDNS.Enabled = false;
175 #Bootstrap = [
176 #];
177 #Swarm.AddrFilters = null;
178 };
179 startWhenNeeded = true;
180 };
181
182 services.udev.packages = [
183 # Allow the console user access the Yubikey USB device node,
184 # needed for challenge/response to work correctly.
185 pkgs.yubikey-personalization
186 ];
187
188 services.xserver = {
189 desktopManager = {
190 session = [
191 # Let the session be generated by home-manager
192 { name = "home-manager";
193 start = ''
194 ${pkgs.runtimeShell} $HOME/.hm-xsession &
195 waitPID=$!
196 '';
197 }
198 ];
199 };
200 displayManager = {
201 defaultSession = "home-manager";
202 #defaultSession = "none+xmonad";
203 #defaultSession = "mate";
204 #defaultSession = "cinnamon";
205 autoLogin = {
206 user = config.users.users.julm.name;
207 };
208 };
209 };
210
211 # This value determines the NixOS release with which your system is to be
212 # compatible, in order to avoid breaking some software such as database
213 # servers. You should change this only after NixOS release notes say you should.
214 system.stateVersion = "20.09"; # Did you read the comment?
215 }