]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/bash.nix
bash: add alias nf
[julm/julm-nix.git] / home-manager / profiles / bash.nix
1 { pkgs, lib, config, ... }:
2 {
3 programs.bash = {
4 enable = lib.mkDefault true;
5 shellAliases = {
6 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
7 c = "bat";
8 cl = "clear";
9 eic = "edit-in-commit";
10 eigg = "edit-in-git-grep";
11 emacs = "emacsclient --create-frame";
12 g = "git";
13 gg = "git grep";
14 grep = "grep --color";
15 j="sudo journalctl -u";
16 jb="sudo journalctl -b";
17 l = "ls -alh";
18 ll = "ls -al";
19 ls = "ls --color=tty";
20 md-toc = "grep '^#\\+' --color";
21 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
22 mem-top = "smem --sort rss --autosize";
23 mpl = "mplayer";
24 nf = "sudo nft list ruleset | less";
25 nixos-clean="sudo nix-collect-garbage -d";
26 nixos-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
27 nixos-rollback="sudo nixos-rebuild switch --rollback";
28 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
29 r = "reset";
30 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
31 s="sudo systemctl";
32 st="sudo systemctl status";
33 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
34 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
35 u="systemctl --user";
36 ut="systemctl --user status";
37 w1 = "watch --color --differences --interval 1";
38 w5 = "watch --color --differences --interval 5";
39 w10 = "watch --color --differences --interval 10";
40 w = "watch --color --differences";
41 watch = "watch --color --differences";
42 yt = "yt-dlp";
43 zfs-umount = "zfs-unmount";
44 };
45 initExtra = ''
46 shopt -s globstar
47 shopt -s histreedit
48 shopt -s histverify
49 # Disable ctrl-s/ctrl-q flow control
50 stty -ixon
51
52 ibm-fan () {
53 if [ $# -gt 0 ]
54 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
55 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
56 fi
57 acpi -t
58 }
59 mkcd () {
60 mkdir -p "$1" &&
61 cd "$1"
62 }
63 smartctl-tbw () {
64 device=''${1:-/dev/sda}
65 sudo smartctl -A $device |
66 { awk '
67 $0 ~ /Power_On_Hours/ { poh=$10; printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25 }
68 $0 ~ /Total_LBAs_Written/ {
69 lbas = $10;
70 bytes = $10 * 512;
71 mb = bytes / 1024^2;
72 gb = bytes / 1024^3;
73 tb = bytes / 1024^4;
74 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
75 printf "mean writes per hour: / %.2f", mb/poh
76 }
77 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
78 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
79 '; echo; } |
80 sed -e 's:/:@:' |
81 sed -e "s\$^\$$device @ \$" |
82 column -ts@
83 }
84 swaplist () {
85 lastpid=
86 swap=0
87 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
88 while IFS=: read -r file x size x
89 do
90 pid=''${file#/proc/}
91 pid=''${pid%/smaps}
92 size=''${size% kB}
93 size=''${size##* }
94 if test "$pid" = "$lastpid"
95 then swap=$(( swap + size ))
96 else
97 if test "$swap" -gt 0
98 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
99 fi
100 if test "$pid" = self
101 then break
102 else
103 lastpid=$pid
104 swap=$size
105 fi
106 fi
107 done |
108 sort -nk1,1
109 }
110 edit-in-commit () { $EDITOR $(git diff-tree --no-commit-id --name-only -r "$@"); }
111 edit-in-git-grep () { $EDITOR $(git grep --name-only --recursive "$@"); }
112 zfs-mount () { for d in $(zfs list -rH -o name "$@"); do sudo zfs mount -l "$d"; done; }
113 zfs-unmount () { sudo zfs unmount -u "$@"; }
114 '';
115 profileExtra = ''
116 '';
117 };
118 programs.direnv.enableBashIntegration = true;
119 #programs.broot.enableBashIntegration = true;
120 home.sessionVariables = {
121 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
122 };
123 programs.readline = {
124 enable = lib.mkDefault true;
125 includeSystemConfig = true;
126 bindings = {
127 "\\eOF" = "end-of-line";
128 "\\eOH" = "beginning-of-line";
129 "\\e[1;5C" = "forward-word";
130 "\\e[1;5D" = "backward-word";
131 "\\e[1~" = "beginning-of-line";
132 "\\e[4~" = "end-of-line";
133 "\\e[5C" = "forward-word";
134 "\\e[5D" = "backward-word";
135 "\\e[7~" = "beginning-of-line";
136 "\\e[8~" = "end-of-line";
137 "\\e[A" = "history-search-backward";
138 "\\e[B" = "history-search-forward";
139 "\\e[F" = "end-of-line";
140 "\\e[H" = "beginning-of-line";
141 "\\e\\e[C" = "forward-word";
142 "\\e\\e[D" = "backward-word";
143 };
144 variables = {
145 colored-completion-prefix = lib.mkDefault true;
146 colored-stats = lib.mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
147 echo-control-characters = lib.mkDefault true;
148 mark-symlinked-directories = lib.mkDefault true;
149 menu-complete-display-prefix = lib.mkDefault true;
150 show-all-if-ambiguous = lib.mkDefault true;
151 show-all-if-unmodified = lib.mkDefault true;
152 visible-stats = lib.mkDefault false; # Append char to indicate type
153 };
154 };
155 }