]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/bash.nix
bash: rename aliases for some git utils
[julm/julm-nix.git] / home-manager / profiles / bash.nix
1 { pkgs, lib, ... }:
2 with lib;
3 {
4 programs.bash = {
5 enable = mkDefault true;
6 shellAliases = {
7 afk = "xset s activate dpms force off";
8 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
9 c = "bat";
10 cl = "clear";
11 emacs = "emacsclient --create-frame";
12 g = "git";
13 ge = "git-edit-commit";
14 gg = "git grep";
15 gge = "git-grep-edit";
16 grep = "grep --color";
17 j = "sudo journalctl -u";
18 jb = "sudo journalctl -b";
19 ju = "sudo journalctl --user -u";
20 l = "ls -alh";
21 ll = "ls -al";
22 ls = "ls --color=tty";
23 md-toc = "grep '^#\\+' --color";
24 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
25 mem-top = "smem --sort rss --autosize";
26 mpl = "mplayer";
27 nf = "sudo nft list ruleset | less";
28 nix-du-svg = "nix-du | dot -Tsvg >nix-du.svg";
29 nixos-clean = "sudo nix-collect-garbage -d";
30 nixos-history = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
31 nixos-rollback = "sudo nixos-rebuild switch --rollback";
32 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
33 r = "reset";
34 rot13 = "tr A-Za-z N-ZA-Mn-za-m";
35 rot135 = "tr A-Za-z0-9 N-ZA-Mn-za-m5-90-4";
36 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
37 s = "sudo systemctl";
38 st = "sudo systemctl status";
39 t = "tmux";
40 t0 = "tmux new -t 0";
41 t1 = "tmux new -t 1";
42 t2 = "tmux new -t 2";
43 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
44 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
45 u = "systemctl --user";
46 ut = "systemctl --user status";
47 w1 = "watch --color --differences --interval 1";
48 w5 = "watch --color --differences --interval 5";
49 w10 = "watch --color --differences --interval 10";
50 w = "watch --color --differences";
51 watch = "watch --color --differences";
52 ze = "sudo zpool export";
53 zfs-umount = "zfs-unmount";
54 zi = "sudo zpool import";
55 zl = "zfs list";
56 zlb = "zfs list -t bookmarks";
57 zls = "zfs list -t snap";
58 zm = "zfs-mount";
59 zu = "zfs-unmount";
60 };
61 sessionVariables = {
62 HISTCONTROL = "erasedups:ignorespace";
63 HISTSIZE = "42000";
64 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
65 };
66 initExtra = ''
67 # Alias completion
68 . ${pkgs.complete-alias}/bin/complete_alias
69 complete -F _complete_alias "''${!BASH_ALIASES[@]}"
70
71 shopt -s globstar
72 shopt -s histappend
73 shopt -s histreedit
74 shopt -s histverify
75 # Disable ctrl-s/ctrl-q flow control
76 stty -ixon
77
78 ffmpeg-audio () {
79 for i in "$@"; do
80 ffmpeg -i "$i" -vn -map 0:a -acodec copy "''${i%.*}".audio
81 done
82 }
83 ffmpeg-opus () {
84 for i in "$@"; do
85 ffmpeg -i "$i" -vn -map 0:a -c:a libopus -b:a 64k -application voip "''${i%.*}".opus
86 done
87 }
88 ibm-fan () {
89 if [ $# -gt 0 ]
90 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
91 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
92 fi
93 acpi -t
94 }
95 mkcd () {
96 mkdir -p "$1" &&
97 cd "$1"
98 }
99 mkpass () {
100 tr -d -C 'A-Za-z0-9' </dev/urandom | head -c 25 | xclip
101 }
102 opusenc-voice () {
103 find "$@" -depth -type f -print0 | sort -n -z |
104 xargs -0 -P "$(lscpu --online -p | grep -v "#" | wc -l)" -I {} bash -c '
105 test -e "''${0%.*}".opus ||
106 nice -n 19 ffmpeg -y -i "$0" -map 0:a -b:a 32k -application voip "''${0%.*}".opus
107 ' {} \;
108 }
109 smartctl-tbw () {
110 device=''${1:-/dev/sda}
111 sudo smartctl -A $device |
112 { awk '
113 $0 ~ /Power_On_Hours/ {
114 poh=$10;
115 printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25
116 }
117 $0 ~ /Total_LBAs_Written/ {
118 lbas = $10;
119 bytes = $10 * 512;
120 mb = bytes / 1024^2;
121 gb = bytes / 1024^3;
122 tb = bytes / 1024^4;
123 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
124 printf "mean writes per hour / %.2f", mb/poh
125 }
126 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
127 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
128 $0 ~ /Percentage Used:/ { printf "Percentage_Used / %d\n", int($3) }
129 '; echo; } |
130 sed -e 's:/:@:' |
131 sed -e "s\$^\$$device @ \$" |
132 column -ts@
133 }
134 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk "/MemAvailable/{ printf \"%d\n\", \$2 * $fac; }" </proc/meminfo)k; }
135 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
136 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
137 swaplist () {
138 lastpid=
139 swap=0
140 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
141 while IFS=: read -r file x size x
142 do
143 pid=''${file#/proc/}
144 pid=''${pid%/smaps}
145 size=''${size% kB}
146 size=''${size##* }
147 if test "$pid" = "$lastpid"
148 then swap=$(( swap + size ))
149 else
150 if test "$swap" -gt 0
151 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
152 fi
153 if test "$pid" = self
154 then break
155 else
156 lastpid=$pid
157 swap=$size
158 fi
159 fi
160 done |
161 sort -nk1,1
162 }
163 git-edit-commit () { $EDITOR $(git diff-tree --no-commit-id --name-only -r "$@"); }
164 git-grep-edit () { $EDITOR $(git grep --name-only --recursive "$@"); }
165
166 # Recursively mount not-mounted dataset,
167 # loading their keys if needed.
168 zfs-mount () {
169 local d
170 local -
171 set -e
172 for d in $(zfs list -rH -o name "$@"); do
173 mountpoint /mnt/"$d" 2>/dev/null ||
174 sudo zfs mount -l "$d"
175 done
176 }
177 # Recursively unmount dataset,
178 # unloading their keys.
179 zfs-unmount () { sudo zfs unmount -u "$@"; }
180
181 # Create bookmarks for all the snapshots of the given datasets.
182 # Bookmarks are only useful on source datasets
183 # But syncoid --create-bookmark only creates
184 # a bookmark for the latest snapshot,
185 # possibly leaving the *_daily or *_monthly snapshots without a bookmark.
186 zfs-fix-bookmarks () {
187 local d
188 local -
189 set -x
190 for d in "$@"; do
191 for s in $(zfs list -Hrpt snapshot -o name "$d"); do
192 zfs bookmark "$s" "''${s//@/#}"
193 done
194 done
195 }
196
197 # Restore the inheritance of encryptionroot,
198 # usually broken by zfs send --raw.
199 # Note that it needs to decrypt the datasets.
200 zfs-fix-encryptionroot () {
201 local d
202 zfs load-key "$1"
203 for d in $(zfs list -rHo name "$1" | tail -n +2); do
204 echo >&2 "$d"
205 test "$(zfs get -Ho value encryptionroot $d)" = "$1" ||
206 zfs change-key -li "$d"
207 done
208 }
209
210 # Recursively remove all the snapshots of given datasets
211 zfs-destroy-snapshots () {
212 local d
213 for d in "$@"; do
214 zfs list -t snapshot -rHo name "$d" |
215 xargs --no-run-if-empty -L1 zfs destroy
216 done
217 }
218 '';
219 profileExtra = ''
220 '';
221 };
222 programs.direnv.enableBashIntegration = true;
223 #programs.broot.enableBashIntegration = true;
224 programs.readline = {
225 enable = mkDefault true;
226 includeSystemConfig = true;
227 bindings = {
228 # Up/Down
229 "\\e[A" = "history-search-backward";
230 "\\e[B" = "history-search-forward";
231 "\\eOA" = "history-search-backward";
232 "\\eOB" = "history-search-forward";
233
234 # Ctrl-Left/Ctrl-Right
235 "\\e[1;5C" = "forward-word";
236 "\\e[1;5D" = "backward-word";
237 "\\e[5C" = "forward-word";
238 "\\e[5D" = "backward-word";
239 "\\e\\e[C" = "forward-word";
240 "\\e\\e[D" = "backward-word";
241
242 # Home/End
243 "\\e[1~" = "beginning-of-line";
244 "\\e[4~" = "end-of-line";
245
246 # Delete/Insert
247 "\\e[3~" = "delete-char";
248 "\\e[2~" = "quoted-insert";
249
250 # For non RH/Debian xterm, can't hurt for RH/Debian xterm
251 "\\eOF" = "end-of-line";
252 "\\eOH" = "beginning-of-line";
253
254 # For freebsd console
255 "\\e[F" = "end-of-line";
256 "\\e[H" = "beginning-of-line";
257
258 # $if term=rxvt
259 "\\e[7~" = "beginning-of-line";
260 "\\e[8~" = "end-of-line";
261 "\\eOc" = "forward-word";
262 "\\eOd" = "backward-word";
263 # $endif
264 };
265 variables = {
266 # Be 8 bit clean.
267 input-meta = mkDefault true;
268 output-meta = mkDefault true;
269 colored-completion-prefix = mkDefault true;
270 colored-stats = mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
271 echo-control-characters = mkDefault true;
272 mark-symlinked-directories = mkDefault true;
273 menu-complete-display-prefix = mkDefault true;
274 show-all-if-ambiguous = mkDefault true;
275 show-all-if-unmodified = mkDefault true;
276 visible-stats = mkDefault false; # Append char to indicate type
277 enable-bracketed-paste = mkDefault true;
278 };
279 };
280 }