5 enable = mkDefault true;
7 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
10 eic = "edit-in-commit";
11 eigg = "edit-in-git-grep";
12 emacs = "emacsclient --create-frame";
15 grep = "grep --color";
16 j = "sudo journalctl -u";
17 jb = "sudo journalctl -b";
18 ju = "sudo journalctl --user -u";
21 ls = "ls --color=tty";
22 md-toc = "grep '^#\\+' --color";
23 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
24 mem-top = "smem --sort rss --autosize";
26 nf = "sudo nft list ruleset | less";
27 nix-du-svg = "nix-du | dot -Tsvg >nix-du.svg";
28 nixos-clean = "sudo nix-collect-garbage -d";
29 nixos-history = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
30 nixos-rollback = "sudo nixos-rebuild switch --rollback";
31 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
33 rot13 = "tr A-Za-z N-ZA-Mn-za-m";
34 rot135 = "tr A-Za-z0-9 N-ZA-Mn-za-m5-90-4";
35 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
37 st = "sudo systemctl status";
42 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
43 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
44 u = "systemctl --user";
45 ut = "systemctl --user status";
46 w1 = "watch --color --differences --interval 1";
47 w5 = "watch --color --differences --interval 5";
48 w10 = "watch --color --differences --interval 10";
49 w = "watch --color --differences";
50 watch = "watch --color --differences";
51 zfs-umount = "zfs-unmount";
54 HISTCONTROL = "erasedups:ignorespace";
56 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
60 . ${pkgs.complete-alias}/bin/complete_alias
61 complete -F _complete_alias "''${!BASH_ALIASES[@]}"
67 # Disable ctrl-s/ctrl-q flow control
72 ffmpeg -i "$i" -vn -map 0:a -acodec copy "''${i%.*}".audio
77 ffmpeg -i "$i" -vn -map 0:a -c:a libopus -b:a 64k -application voip "''${i%.*}".opus
82 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
83 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
92 tr -d -C 'A-Za-z0-9' </dev/urandom | head -c 25 | xclip
95 find "$@" -depth -type f -print0 | sort -n -z |
96 xargs -0 -P "$(lscpu --online -p | grep -v "#" | wc -l)" -I {} bash -c '
97 test -e "''${0%.*}".opus ||
98 nice -n 19 ffmpeg -y -i "$0" -map 0:a -b:a 32k -application voip "''${0%.*}".opus
102 device=''${1:-/dev/sda}
103 sudo smartctl -A $device |
105 $0 ~ /Power_On_Hours/ { poh=$10; printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25 }
106 $0 ~ /Total_LBAs_Written/ {
112 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
113 printf "mean writes per hour: / %.2f", mb/poh
115 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
116 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
119 sed -e "s\$^\$$device @ \$" |
122 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk "/MemAvailable/{ printf \"%d\n\", \$2 * $fac; }" </proc/meminfo)k; }
123 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
124 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
128 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
129 while IFS=: read -r file x size x
135 if test "$pid" = "$lastpid"
136 then swap=$(( swap + size ))
138 if test "$swap" -gt 0
139 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
141 if test "$pid" = self
151 edit-in-commit () { $EDITOR $(git diff-tree --no-commit-id --name-only -r "$@"); }
152 edit-in-git-grep () { $EDITOR $(git grep --name-only --recursive "$@"); }
154 # Recursively mount not-mounted dataset,
155 # loading their keys if needed.
160 for d in $(zfs list -rH -o name "$@"); do
161 mountpoint /mnt/"$d" 2>/dev/null ||
162 sudo zfs mount -l "$d"
165 # Recursively unmount dataset,
166 # unloading their keys.
167 zfs-unmount () { sudo zfs unmount -u "$@"; }
169 # Restore the inheritance of encryptionroot,
170 # usually broken by zfs send --raw.
171 # Note that it needs to decrypt the datasets.
172 zfs-fix-encryptionroot () {
175 for d in $(zfs list -rHo name "$1" | tail -n +2); do
177 test "$(zfs get -Ho value encryptionroot $d)" = "$1" ||
178 zfs change-key -li "$d"
182 # Recursively remove all the snapshots of given datasets
183 zfs-destroy-snapshots () {
186 zfs list -t snapshot -rHo name "$d" |
187 xargs --no-run-if-empty -L1 zfs destroy
194 programs.direnv.enableBashIntegration = true;
195 #programs.broot.enableBashIntegration = true;
196 programs.readline = {
197 enable = mkDefault true;
198 includeSystemConfig = true;
201 "\\e[A" = "history-search-backward";
202 "\\e[B" = "history-search-forward";
203 "\\eOA" = "history-search-backward";
204 "\\eOB" = "history-search-forward";
206 # Ctrl-Left/Ctrl-Right
207 "\\e[1;5C" = "forward-word";
208 "\\e[1;5D" = "backward-word";
209 "\\e[5C" = "forward-word";
210 "\\e[5D" = "backward-word";
211 "\\e\\e[C" = "forward-word";
212 "\\e\\e[D" = "backward-word";
215 "\\e[1~" = "beginning-of-line";
216 "\\e[4~" = "end-of-line";
219 "\\e[3~" = "delete-char";
220 "\\e[2~" = "quoted-insert";
222 # For non RH/Debian xterm, can't hurt for RH/Debian xterm
223 "\\eOF" = "end-of-line";
224 "\\eOH" = "beginning-of-line";
226 # For freebsd console
227 "\\e[F" = "end-of-line";
228 "\\e[H" = "beginning-of-line";
231 "\\e[7~" = "beginning-of-line";
232 "\\e[8~" = "end-of-line";
233 "\\eOc" = "forward-word";
234 "\\eOd" = "backward-word";
239 input-meta = mkDefault true;
240 output-meta = mkDefault true;
241 colored-completion-prefix = mkDefault true;
242 colored-stats = mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
243 echo-control-characters = mkDefault true;
244 mark-symlinked-directories = mkDefault true;
245 menu-complete-display-prefix = mkDefault true;
246 show-all-if-ambiguous = mkDefault true;
247 show-all-if-unmodified = mkDefault true;
248 visible-stats = mkDefault false; # Append char to indicate type
249 enable-bracketed-paste = mkDefault true;