]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/bash.nix
bash: alias ju
[julm/julm-nix.git] / home-manager / profiles / bash.nix
1 { pkgs, lib, ... }:
2 with lib;
3 {
4 programs.bash = {
5 enable = mkDefault true;
6 enableCompletion = mkDefault true;
7 shellAliases = {
8 afk = "xset s activate dpms force off";
9 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
10 c = "bat";
11 cl = "clear";
12 dust = "dust --bars-on-right --full-paths";
13 emacs = "emacsclient --create-frame";
14 grep = "grep --color";
15 j = "sudo journalctl -u";
16 jb = "sudo journalctl -b";
17 ju = "journalctl --user -u";
18 l = "ls -alh";
19 ll = "ls -al";
20 ls = "ls --color=tty";
21 md-toc = "grep '^#\\+' --color";
22 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
23 mem-top = "smem --sort rss --autosize";
24 mpl = "mplayer";
25 n = "sudo networkctl";
26 nf = "sudo nft list ruleset | less";
27 nix-du-svg = "nix-du | dot -Tsvg >nix-du.svg";
28 nixos-clean = "sudo nix-collect-garbage -d";
29 nixos-history = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
30 nixos-rollback = "sudo nixos-rebuild switch --rollback";
31 nt = "sudo networkctl status";
32 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
33 r = "reset";
34 rot13 = "tr A-Za-z N-ZA-Mn-za-m";
35 rot135 = "tr A-Za-z0-9 N-ZA-Mn-za-m5-90-4";
36 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
37 s = "sudo systemctl";
38 sr = "sudo systemctl restart";
39 ssh-unknown = "ssh -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null";
40 st = "sudo systemctl status";
41 t = "tmux";
42 t0 = "tmux new -t 0";
43 t1 = "tmux new -t 1";
44 t2 = "tmux new -t 2";
45 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
46 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
47 u = "systemctl --user";
48 ur = "systemctl --user restart";
49 ut = "systemctl --user status";
50 w = "watch --color --differences";
51 w1 = "watch --color --differences --interval 1";
52 w10 = "watch --color --differences --interval 10";
53 w5 = "watch --color --differences --interval 5";
54 watch = "watch --color --differences";
55 z = "zfs";
56 ze = "sudo zpool export";
57 zfs-umount = "zfs-unmount";
58 zi = "sudo zpool import";
59 zl = "zfs list";
60 zlb = "zfs list -t bookmarks";
61 zls = "zfs list -t snap";
62 zm = "zfs-mount";
63 zp = "sudo zpool";
64 zs = "zpool status";
65 zs5 = "w5 zpool status";
66 zu = "zfs-unmount";
67 };
68 historyControl = [ "erasedups" "ignorespace" ];
69 historyIgnore = [
70 "torify"
71 "mpv"
72 ];
73 historySize = 42000;
74 sessionVariables = {
75 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
76 # More throughput than chacha20-poly1305@openssh.com
77 # on hardware with AES acceleration.
78 RSYNC_RSH = "ssh -c aes128-gcm@openssh.com,chacha20-poly1305@openssh.com";
79 };
80 initExtra = ''
81 # Alias completion
82 . ${pkgs.complete-alias}/bin/complete_alias
83 complete -F _complete_alias "''${!BASH_ALIASES[@]}"
84
85 shopt -s globstar
86 shopt -s histappend
87 shopt -s histreedit
88 shopt -s histverify
89 # Disable ctrl-s/ctrl-q flow control
90 stty -ixon
91
92 ffmpeg-audio () {
93 for i in "$@"; do
94 ffmpeg -i "$i" -vn -map 0:a -acodec copy "''${i%.*}".audio-only.mkv
95 done
96 }
97 ffmpeg-opus () {
98 for i in "$@"; do
99 ffmpeg -i "$i" -vn -map 0:a -c:a libopus -b:a 64k -application voip "''${i%.*}".opus
100 done
101 }
102 opusenc-voice () {
103 find "$@" -depth -type f -print0 | sort -n -z |
104 xargs -0 -P "$(lscpu --online -p | grep -v "#" | wc -l)" -I {} bash -c '
105 test -e "''${0%.*}".opus ||
106 nice -n 19 ffmpeg -y -i "$0" -map 0:a -b:a 32k -application voip "''${0%.*}".opus
107 ' {} \;
108 }
109 ibm-fan () {
110 if [ $# -gt 0 ]
111 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
112 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
113 fi
114 acpi -t
115 }
116 mkcd () {
117 mkdir -p "$1" &&
118 cd "$1"
119 }
120 mkpass () {
121 tr -d -C 'A-Za-z0-9' </dev/urandom | head -c 25 | xclip
122 }
123 smartctl-tbw () {
124 device=''${1:-/dev/sda}
125 sudo smartctl -A $device |
126 { awk '
127 $0 ~ /Power_On_Hours/ {
128 poh=$10;
129 printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25
130 }
131 $0 ~ /Total_LBAs_Written/ {
132 lbas = $10;
133 bytes = $10 * 512;
134 mb = bytes / 1024^2;
135 gb = bytes / 1024^3;
136 tb = bytes / 1024^4;
137 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
138 printf "mean writes per hour / %.2f", mb/poh
139 }
140 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
141 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
142 $0 ~ /Percentage Used:/ { printf "Percentage_Used / %d\n", int($3) }
143 '; echo; } |
144 sed -e 's:/:@:' |
145 sed -e "s\$^\$$device @ \$" |
146 column -ts@
147 }
148 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk "/MemAvailable/{ printf \"%d\n\", \$2 * $fac; }" </proc/meminfo)k; }
149 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
150 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
151 swaplist () {
152 lastpid=
153 swap=0
154 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
155 while IFS=: read -r file x size x
156 do
157 pid=''${file#/proc/}
158 pid=''${pid%/smaps}
159 size=''${size% kB}
160 size=''${size##* }
161 if test "$pid" = "$lastpid"
162 then swap=$(( swap + size ))
163 else
164 if test "$swap" -gt 0
165 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
166 fi
167 if test "$pid" = self
168 then break
169 else
170 lastpid=$pid
171 swap=$size
172 fi
173 fi
174 done |
175 sort -nk1,1
176 }
177
178 # Recursively mount not-mounted dataset,
179 # loading their keys if needed.
180 zfs-mount () {
181 (
182 set -e
183 for d in $(zfs list -rH -o name "$@"); do
184 mountpoint /mnt/"$d" 2>/dev/null ||
185 sudo zfs mount -l "$d"
186 done
187 )
188 }
189 # Recursively unmount dataset,
190 # unloading their keys.
191 zfs-unmount () { sudo zfs unmount -u "$@"; }
192
193 # Create bookmarks for all the snapshots of the given datasets.
194 # Bookmarks are only useful on source datasets
195 # But syncoid --create-bookmark only creates
196 # a bookmark for the latest snapshot,
197 # possibly leaving the *_daily or *_monthly snapshots without a bookmark.
198 zfs-fix-bookmarks () {
199 local d
200 local -
201 set -x
202 for d in "$@"; do
203 for s in $(zfs list -Hrpt snapshot -o name "$d"); do
204 zfs bookmark "$s" "''${s//@/#}"
205 done
206 done
207 }
208
209 # Restore the inheritance of encryptionroot,
210 # usually broken by zfs send --raw.
211 # Note that it needs to decrypt the datasets.
212 zfs-fix-encryptionroot () {
213 local d
214 zfs load-key "$1"
215 for d in $(zfs list -rHo name "$1" | tail -n +2); do
216 echo >&2 "$d"
217 test "$(zfs get -Ho value encryptionroot $d)" = "$1" ||
218 zfs change-key -li "$d"
219 done
220 }
221
222 # Recursively remove all the snapshots of given datasets
223 zfs-destroy-snapshots () {
224 local d
225 for d in "$@"; do
226 zfs list -t snapshot -rHo name "$d" |
227 xargs --no-run-if-empty -L1 zfs destroy
228 done
229 }
230 '';
231 profileExtra = ''
232 '';
233 };
234 #programs.broot.enableBashIntegration = true;
235 programs.readline = {
236 enable = mkDefault true;
237 includeSystemConfig = true;
238 bindings = {
239 # Up/Down
240 "\\e[A" = "history-search-backward";
241 "\\e[B" = "history-search-forward";
242 "\\eOA" = "history-search-backward";
243 "\\eOB" = "history-search-forward";
244
245 # Ctrl-Left/Ctrl-Right
246 "\\e[1;5C" = "forward-word";
247 "\\e[1;5D" = "backward-word";
248 "\\e[5C" = "forward-word";
249 "\\e[5D" = "backward-word";
250 "\\e\\e[C" = "forward-word";
251 "\\e\\e[D" = "backward-word";
252
253 # Home/End
254 "\\e[1~" = "beginning-of-line";
255 "\\e[4~" = "end-of-line";
256
257 # Delete/Insert
258 "\\e[3~" = "delete-char";
259 "\\e[2~" = "quoted-insert";
260
261 # For non RH/Debian xterm, can't hurt for RH/Debian xterm
262 "\\eOF" = "end-of-line";
263 "\\eOH" = "beginning-of-line";
264
265 # For freebsd console
266 "\\e[F" = "end-of-line";
267 "\\e[H" = "beginning-of-line";
268
269 # $if term=rxvt
270 "\\e[7~" = "beginning-of-line";
271 "\\e[8~" = "end-of-line";
272 "\\eOc" = "forward-word";
273 "\\eOd" = "backward-word";
274 # $endif
275 };
276 variables = {
277 # Be 8 bit clean.
278 input-meta = mkDefault true;
279 output-meta = mkDefault true;
280 colored-completion-prefix = mkDefault true;
281 colored-stats = mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
282 echo-control-characters = mkDefault true;
283 mark-symlinked-directories = mkDefault true;
284 menu-complete-display-prefix = mkDefault true;
285 show-all-if-ambiguous = mkDefault true;
286 show-all-if-unmodified = mkDefault true;
287 visible-stats = mkDefault false; # Append char to indicate type
288 enable-bracketed-paste = mkDefault true;
289 };
290 };
291 }