]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/htop.nix
htop: show kernel threads
[julm/julm-nix.git] / home-manager / profiles / htop.nix
1 { pkgs, lib, config, ...}:
2 {
3 # This must appear before "column_meters_*" options
4 xdg.configFile."htop/htoprc".text = lib.mkBefore ''
5 header_layout=two_50_50
6 '';
7 home.packages = [ pkgs.htop ];
8 programs.htop = {
9 enable = lib.mkDefault true;
10 settings = {
11 account_guest_in_cpu_meter = false;
12 all_branches_collapsed = false;
13 color_scheme = false;
14 column_meter_modes_0 = "3 1 1 1";
15 column_meter_modes_1 = "2 2 2 3 1 3 1 1 1 1";
16 column_meters_0 = "AllCPUs Memory Swap Zram";
17 column_meters_1 = "Systemd LoadAverage Uptime DiskIO DiskIO NetworkIO NetworkIO ZFSARC ZFSCARC PressureStallIOFull";
18 cpu_count_from_one = false;
19 degree_fahrenheit = false;
20 delay = 15;
21 detailed_cpu_time = true;
22 enable_mouse = true;
23 find_comm_in_cmdline = true;
24 header_margin = true;
25 hide_function_bar = false;
26 hide_kernel_threads = false;
27 hide_threads = true;
28 hide_userland_threads = false;
29 highlight_base_name = true;
30 highlight_changes = false;
31 highlight_changes_delay_secs = 5;
32 highlight_deleted_exe = true;
33 highlight_megabytes = true;
34 highlight_threads = true;
35 shadow_other_users = false;
36 show_cpu_frequency = true;
37 show_cpu_temperature = false;
38 show_cpu_usage = true;
39 show_merged_command = false;
40 show_program_path = false;
41 show_thread_names = false;
42 sort_direction = 0;
43 sort_key = 46; # PERCENT_CPU
44 strip_exe_from_cmdline = true;
45 tree_sort_direction = 0;
46 tree_sort_key = 46; # PERCENT_CPU
47 tree_view = true;
48 tree_view_always_by_pid = false;
49 update_process_names = false;
50 };
51 };
52 }