]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/options.nix
build: add script
[julm/julm-nix.git] / home-manager / options.nix
1 { pkgs, lib, config, ... }:
2 with builtins;
3 {
4 options.host = {
5 hardware = lib.mkOption {
6 type = with lib.types; listOf str;
7 default = filter (x: isString x && x != "") (split "[ \n]+" (readFile
8 "/sys/devices/virtual/dmi/id/product_name"));
9 description = "hardware";
10 };
11 };
12 }