]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/patate/hardware.nix
veloren: update and fix
[julm/julm-nix.git] / hosts / patate / hardware.nix
1 { hostName, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/hardware/X200.nix
5 ../../nixos/profiles/zfs.nix
6 ../../nixos/profiles/zramSwap.nix
7 ];
8
9 boot.loader.grub = {
10 enable = true;
11 memtest86.enable = true;
12 device = "/dev/disk/by-id/ata-CT250MX500SSD1_2004E2849DD1";
13 configurationLimit = 3;
14 };
15 boot.zfs.requestEncryptionCredentials = [ hostName ];
16
17 fileSystems."/boot" = {
18 device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
19 fsType = "ext2";
20 };
21 fileSystems."/boot/efi" = {
22 device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
23 fsType = "vfat";
24 };
25 swapDevices = [
26 {
27 device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
28 randomEncryption = {
29 enable = true;
30 cipher = "aes-xts-plain64";
31 source = "/dev/urandom";
32 };
33 }
34 ];
35
36 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
37 # You should try to make this id unique among your hosts.
38 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
39 networking.hostId = "ec2adb40";
40
41 boot.supportedFilesystems = [
42 "ntfs"
43 "vfat"
44 ];
45 boot.extraModulePackages = [
46 #config.boot.kernelPackages.exfat-nofuse
47 ];
48
49 powerManagement.powertop.enable = true;
50
51 fileSystems."/" = {
52 device = "${hostName}/root";
53 fsType = "zfs";
54 };
55 fileSystems."/nix" = {
56 device = "${hostName}/nix";
57 fsType = "zfs";
58 };
59 fileSystems."/home/sevy" = {
60 device = "${hostName}/home";
61 fsType = "zfs";
62 };
63 fileSystems."/home/sevy/Documents" = {
64 device = "${hostName}/home/Documents";
65 fsType = "zfs";
66 };
67 fileSystems."/home/sevy/Images" = {
68 device = "${hostName}/home/Images";
69 fsType = "zfs";
70 };
71 fileSystems."/home/sevy/Téléchargements" = {
72 device = "${hostName}/home/Downloads";
73 fsType = "zfs";
74 };
75 fileSystems."/home/sevy/.thunderbird" = {
76 device = "${hostName}/home/Mails";
77 fsType = "zfs";
78 };
79 fileSystems."/home/sevy/Vidéos" = {
80 device = "${hostName}/home/Videos";
81 fsType = "zfs";
82 };
83 fileSystems."/var" = {
84 device = "${hostName}/var";
85 fsType = "zfs";
86 };
87 fileSystems."/var/cache" = {
88 device = "${hostName}/var/cache";
89 fsType = "zfs";
90 };
91 fileSystems."/var/log" = {
92 device = "${hostName}/var/log";
93 fsType = "zfs";
94 };
95 fileSystems."/var/tmp" = {
96 device = "${hostName}/var/tmp";
97 fsType = "zfs";
98 };
99
100 }