4 ../../nixos/profiles/hardware/X200.nix
5 ../../nixos/profiles/zfs.nix
6 ../../nixos/profiles/zramSwap.nix
11 memtest86.enable = true;
12 device = "/dev/disk/by-id/ata-CT250MX500SSD1_2004E2849DD1";
13 configurationLimit = 3;
15 boot.zfs.requestEncryptionCredentials = [ hostName ];
17 fileSystems."/boot" = {
18 device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
21 fileSystems."/boot/efi" = {
22 device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
27 device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
30 cipher = "aes-xts-plain64";
31 source = "/dev/urandom";
36 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
37 # You should try to make this id unique among your hosts.
38 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
39 networking.hostId = "ec2adb40";
41 boot.supportedFilesystems = [
45 boot.extraModulePackages = [
46 #config.boot.kernelPackages.exfat-nofuse
49 powerManagement.powertop.enable = true;
52 device = "${hostName}/root";
55 fileSystems."/nix" = {
56 device = "${hostName}/nix";
59 fileSystems."/home/sevy" = {
60 device = "${hostName}/home";
63 fileSystems."/home/sevy/Documents" = {
64 device = "${hostName}/home/Documents";
67 fileSystems."/home/sevy/Images" = {
68 device = "${hostName}/home/Images";
71 fileSystems."/home/sevy/Téléchargements" = {
72 device = "${hostName}/home/Downloads";
75 fileSystems."/home/sevy/.thunderbird" = {
76 device = "${hostName}/home/Mails";
79 fileSystems."/home/sevy/Vidéos" = {
80 device = "${hostName}/home/Videos";
83 fileSystems."/var" = {
84 device = "${hostName}/var";
87 fileSystems."/var/cache" = {
88 device = "${hostName}/var/cache";
91 fileSystems."/var/log" = {
92 device = "${hostName}/var/log";
95 fileSystems."/var/tmp" = {
96 device = "${hostName}/var/tmp";