]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/patate/hardware.nix
courge: install
[julm/julm-nix.git] / hosts / patate / hardware.nix
1 { hostName, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/hardware/X200.nix
5 ../../nixos/profiles/zfs.nix
6 ../../nixos/profiles/zramSwap.nix
7 ];
8
9 boot.loader.grub = {
10 enable = true;
11 memtest86.enable = true;
12 device = "/dev/disk/by-id/ata-CT250MX500SSD1_2004E2849DD1";
13 configurationLimit = 3;
14 };
15 boot.zfs.requestEncryptionCredentials = [ hostName ];
16
17 fileSystems."/boot" =
18 {
19 device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
20 fsType = "ext2";
21 };
22 fileSystems."/boot/efi" =
23 {
24 device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
25 fsType = "vfat";
26 };
27 swapDevices = [
28 {
29 device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
30 randomEncryption = {
31 enable = true;
32 cipher = "aes-xts-plain64";
33 source = "/dev/urandom";
34 };
35 }
36 ];
37
38 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
39 # You should try to make this id unique among your hosts.
40 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
41 networking.hostId = "ec2adb40";
42
43 boot.supportedFilesystems = [ "ntfs" "vfat" ];
44 boot.extraModulePackages = [
45 #config.boot.kernelPackages.exfat-nofuse
46 ];
47
48 powerManagement.powertop.enable = true;
49
50 fileSystems."/" =
51 {
52 device = "${hostName}/root";
53 fsType = "zfs";
54 };
55 fileSystems."/nix" =
56 {
57 device = "${hostName}/nix";
58 fsType = "zfs";
59 };
60 fileSystems."/home/sevy" =
61 {
62 device = "${hostName}/home";
63 fsType = "zfs";
64 };
65 fileSystems."/home/sevy/Documents" =
66 {
67 device = "${hostName}/home/Documents";
68 fsType = "zfs";
69 };
70 fileSystems."/home/sevy/Images" =
71 {
72 device = "${hostName}/home/Images";
73 fsType = "zfs";
74 };
75 fileSystems."/home/sevy/Téléchargements" =
76 {
77 device = "${hostName}/home/Downloads";
78 fsType = "zfs";
79 };
80 fileSystems."/home/sevy/.thunderbird" =
81 {
82 device = "${hostName}/home/Mails";
83 fsType = "zfs";
84 };
85 fileSystems."/home/sevy/Vidéos" =
86 {
87 device = "${hostName}/home/Videos";
88 fsType = "zfs";
89 };
90 fileSystems."/var" =
91 {
92 device = "${hostName}/var";
93 fsType = "zfs";
94 };
95 fileSystems."/var/cache" =
96 {
97 device = "${hostName}/var/cache";
98 fsType = "zfs";
99 };
100 fileSystems."/var/log" =
101 {
102 device = "${hostName}/var/log";
103 fsType = "zfs";
104 };
105 fileSystems."/var/tmp" =
106 {
107 device = "${hostName}/var/tmp";
108 fsType = "zfs";
109 };
110
111 }