]> Git — Sourcephile - julm/julm-nix.git/blob - nixos/profiles/wireguard/wg-intra/peers.nix
courge: install
[julm/julm-nix.git] / nixos / profiles / wireguard / wg-intra / peers.nix
1 {
2 mermet = rec {
3 ipv4 = "192.168.42.1";
4 ips = [ "${ipv4}/24" ];
5 listenPort = 43642;
6 peersAnnouncing.enable = true;
7 peer = {
8 publicKey = "XbTEP2X71LBTjmdmySdiOpQJ+uIomcXvg1aiQGUtWBI=";
9 allowedIPs = [ "${ipv4}/32" ];
10 endpoint = "80.67.180.129:${toString listenPort}";
11 endpointsUpdater.enable = true;
12 # No need to keepalive each second like the others
13 persistentKeepalive = 20;
14 };
15 };
16 losurdo = rec {
17 ipv4 = "192.168.42.2";
18 ips = [ "${ipv4}/24" ];
19 listenPort = 43643;
20 persistentKeepalive = 10;
21 peer = {
22 publicKey = "xsFFep3k8z0pXgUOz4aryOF8l/KPBSOd4WQA26BkXy0=";
23 allowedIPs = [ "${ipv4}/32" ];
24 };
25 };
26 oignon = rec {
27 ipv4 = "192.168.42.3";
28 ips = [ "${ipv4}/24" ];
29 listenPort = 43644;
30 persistentKeepalive = 10;
31 peer = {
32 publicKey = "tE4fzqDrr7BgfOo9tWgGnpu3v0JRDEUZbJnm9e2F/GA=";
33 allowedIPs = [ "${ipv4}/32" ];
34 #dynamicEndpointRefreshSeconds = 60;
35 };
36 };
37 patate = rec {
38 ipv4 = "192.168.42.4";
39 ips = [ "${ipv4}/24" ];
40 listenPort = 43641;
41 persistentKeepalive = 10;
42 peer = {
43 publicKey = "gaEz7nvJTk4h3DGOpeZXSWmYDDrc5xQkuJ28sGrksx4=";
44 allowedIPs = [ "${ipv4}/32" ];
45 #dynamicEndpointRefreshSeconds = 60;
46 };
47 };
48 carotte = rec {
49 ipv4 = "192.168.42.5";
50 ips = [ "${ipv4}/24" ];
51 listenPort = 43646;
52 persistentKeepalive = 10;
53 peer = {
54 publicKey = "33yNfMAIRMjwqwYszPzVGqclkAGgW6RGsnBnSzRKXm0=";
55 allowedIPs = [ "${ipv4}/32" ];
56 #dynamicEndpointRefreshSeconds = 60;
57 };
58 };
59 aubergine = rec {
60 ipv4 = "192.168.42.6";
61 ips = [ "${ipv4}/24" ];
62 listenPort = 43646;
63 persistentKeepalive = 10;
64 peer = {
65 publicKey = "NQYHx9+VhwtF220JzBukV5rUB8j0hHMoOxDakwJx6UM=";
66 allowedIPs = [ "${ipv4}/32" ];
67 dynamicEndpointRefreshSeconds = 60;
68 };
69 };
70 courge = rec {
71 ipv4 = "192.168.42.7";
72 ips = [ "${ipv4}/24" ];
73 listenPort = 43647;
74 persistentKeepalive = 30;
75 peer = {
76 publicKey = "6f9qhj/MDTm0dehld3zIeDLpGRvbYU1XmRgpYZqkeQU=";
77 allowedIPs = [ "${ipv4}/32" ];
78 dynamicEndpointRefreshSeconds = 60;
79 };
80 };
81 }