]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/patate/ilico.nix
patate: tweak davfs2
[julm/julm-nix.git] / hosts / patate / ilico.nix
1 { config, pkgs, lib, ... }:
2 {
3 services.davfs2.enable = true;
4 users.users.sevy.extraGroups = [
5 config.services.davfs2.davGroup
6 ];
7 fileSystems."/home/sevy/mnt/ilico/severine" = {
8 device = "https://nuage.ilico.org/remote.php/dav/files/severine/";
9 fsType = "davfs";
10 options =
11 let conf = pkgs.writeText "davfs2.conf" ''
12 backup_dir /home/sevy/Documents/EnTransfert/ilico/severine
13 cache_dir /home/sevy/.cache/davfs2/ilico/severine
14 secrets /home/sevy/.davfs2/secrets
15 ''; in
16 [ "conf=${conf}" "user" "noexec" "nosuid"
17 "noauto" "nofail" "_netdev" "reconnect"
18 "x-systemd.automount"
19 "x-systemd.device-timeout=1m"
20 "x-systemd.idle-timeout=1m"
21 "x-systemd.mount-timeout=10s"
22 ];
23 };
24 }