]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/yt-dlp.nix
yt-dlp: enable --embed-subs
[julm/julm-nix.git] / home-manager / profiles / yt-dlp.nix
1 { pkgs, lib, config, ... }:
2 {
3 imports = [
4 ./aria2c.nix
5 ];
6 home.packages = [
7 pkgs.phantomjs
8 pkgs.yt-dlp
9 ];
10 xdg.configFile."yt-dlp/config".text = ''
11 #--download-archive .downloaded
12 --embed-subs
13 --format ${lib.concatStringsSep "/" [
14 #"bestvideo[height=360][ext=mp4]+bestaudio"
15 "bestvideo[height=480][ext=mp4]+bestaudio"
16 #"best[height=360][ext=mp4]"
17 "best[height=480][ext=mp4]"
18 #"best[height=360]"
19 "best[height=480]"
20 "best"
21 ]}
22 --output "%(upload_date>%Y-%m-%d)s - %(title)s.%(id)s.%(format_id)s.%(ext)s"
23 --prefer-free-formats
24 '';
25 }