1 { pkgs, lib, hostName, ... }:
4 ../../nixos/profiles/hardware/apu6b4.nix
5 ../../nixos/profiles/hardware/ME909u-521.nix
6 ../../nixos/profiles/serial.nix
7 ../../nixos/profiles/zfs.nix
8 ../../nixos/profiles/zramSwap.nix
11 # Setting the machine-id avoids to reencrypt all credentials
12 # when reinstalling NixOS on a new drive.
13 # Manually generated with : uuidgen | tr -d -
14 environment.etc.machine-id.source = ./machine-id.clear;
16 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
17 # You should try to make this id unique among your hosts.
18 # Manually generated with : uuidgen | head -c8
19 networking.hostId = "408a404a";
23 canTouchEfiVariables = true;
24 efiSysMountPoint = "/boot/efi";
30 #"/dev/disk/by-id/mmc-SU08G_0xb0320f0f"
31 #"/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
32 "/dev/disk/by-id/ata-YMTC_JGS_2201060101833"
34 configurationLimit = 9;
38 #enableCryptodisk = true;
41 boot.supportedFilesystems = [ /*"ntfs"*/ "vfat" ];
42 boot.extraModulePackages = [
43 #config.boot.kernelPackages.exfat-nofuse
45 boot.zfs.requestEncryptionCredentials = [ hostName ];
47 hardware.enableRedistributableFirmware = true;
49 powerManagement.powertop.enable = true;
51 #services.fprintd.enable = true;
55 device = "${hostName}/root";
60 device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
63 fileSystems."/boot/efi" =
65 device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
70 device = "${hostName}/nix";
75 device = "${hostName}/var";
80 device = "${hostName}/home";
86 device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
89 cipher = "aes-xts-plain64";
90 source = "/dev/urandom";
95 hardware.pulseaudio.enable = lib.mkDefault true;
96 #hardware.pulseaudio.tcp.enable = lib.mkDefault true;