]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/aubergine/hardware.nix
aubergine: clean code
[julm/julm-nix.git] / hosts / aubergine / hardware.nix
1 { pkgs, lib, hostName, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/hardware/apu6b4.nix
5 ../../nixos/profiles/hardware/ME909u-521.nix
6 ../../nixos/profiles/serial.nix
7 ../../nixos/profiles/zfs.nix
8 ../../nixos/profiles/zramSwap.nix
9 ];
10
11 # Setting the machine-id avoids to reencrypt all credentials
12 # when reinstalling NixOS on a new drive.
13 # Manually generated with : uuidgen | tr -d -
14 environment.etc.machine-id.source = ./machine-id.clear;
15
16 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
17 # You should try to make this id unique among your hosts.
18 # Manually generated with : uuidgen | head -c8
19 networking.hostId = "408a404a";
20
21 /*
22 boot.loader.efi = {
23 canTouchEfiVariables = true;
24 efiSysMountPoint = "/boot/efi";
25 };
26 */
27 boot.loader.grub = {
28 enable = true;
29 devices = [
30 #"/dev/disk/by-id/mmc-SU08G_0xb0320f0f"
31 #"/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
32 "/dev/disk/by-id/ata-YMTC_JGS_2201060101833"
33 ];
34 configurationLimit = 9;
35
36 #zfsSupport = true;
37 #efiSupport = true;
38 #enableCryptodisk = true;
39 };
40
41 boot.supportedFilesystems = [ /*"ntfs"*/ "vfat" ];
42 boot.extraModulePackages = [
43 #config.boot.kernelPackages.exfat-nofuse
44 ];
45
46 hardware.enableRedistributableFirmware = true;
47
48 powerManagement.powertop.enable = true;
49
50 #services.fprintd.enable = true;
51
52 fileSystems."/" =
53 {
54 device = "${hostName}/root";
55 fsType = "zfs";
56 };
57 fileSystems."/boot" =
58 {
59 device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
60 fsType = "ext4";
61 };
62 fileSystems."/boot/efi" =
63 {
64 device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
65 fsType = "vfat";
66 };
67 fileSystems."/nix" =
68 {
69 device = "${hostName}/nix";
70 fsType = "zfs";
71 };
72 fileSystems."/var" =
73 {
74 device = "${hostName}/var";
75 fsType = "zfs";
76 };
77 fileSystems."/home" =
78 {
79 device = "${hostName}/home";
80 fsType = "zfs";
81 };
82 swapDevices =
83 [
84 {
85 device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
86 randomEncryption = {
87 enable = true;
88 cipher = "aes-xts-plain64";
89 source = "/dev/urandom";
90 };
91 }
92 ];
93
94 hardware.pulseaudio.enable = lib.mkDefault true;
95 #hardware.pulseaudio.tcp.enable = lib.mkDefault true;
96
97 }