]> Git — Sourcephile - julm/julm-nix.git/blob - homes/softwares/urxvt.nix
urxvt: add cutchars
[julm/julm-nix.git] / homes / softwares / urxvt.nix
1 {
2 home.file.".Xresources".text = ''
3 URxvt.cutchars:"()*,<>[]{}|│::、。
4 URxvt*termName: xterm-256color
5 URxvt*letterSpace: 0
6 URxvt*lineSpace: 0
7 URxvt*font:xft:DejaVu Sans Mono:size=7.38
8 URxvt*buffered: true
9 URxvt*depth: 32
10 URxvt*background: black
11 URxvt*cursorBlink: on
12 URxvt*cursorColor2: black
13 URxvt*cursorColor: #00B10B
14 URxvt*fading: 0
15 URxvt*foreground: white
16 URxvt*geometry: 61x20
17 URxvt*highlightColor: red
18 URxvt*insecure: True
19 URxvt*internalBorder: 2
20 URxvt*jumpScroll: on
21 URxvt*keysym.C-ISO_Left_Tab: \033[27;6;9~
22 URxvt*keysym.C-Tab: \033[27;5;9~
23 URxvt*keysym.KP_End: \033[4~
24 URxvt*keysym.KP_Enter: \n
25 URxvt*keysym.KP_Home: \033[1~
26 URxvt*meta8: False
27 URxvt*pointerColor2: black
28 URxvt*pointerColor: green
29 URxvt*reverseVideo: false
30 URxvt*saveLines: 0
31 URxvt*scrollBar_floating: on
32 URxvt*scrollBar_right: on
33 URxvt*scrollColor: grey20
34 URxvt*scrollTtyKeypress: on
35 URxvt*scrollTtyOutput: off
36 URxvt*scrollWithBuffer: on
37 URxvt*scrollbar*foreground: blue
38 URxvt*scrollstyle: plain
39 URxvt*troughColor: blue
40 URxvt*visualBell: off
41 URxvt.font-size.step: 1
42 URxvt.iso14755_52: False
43 URxvt.keysym.C-Down: perl:font-size:decrease
44 URxvt.keysym.C-S-Down: perl:font-size:decglobal
45 URxvt.keysym.C-S-Up: perl:font-size:incglobal
46 URxvt.keysym.C-Up: perl:font-size:increase
47 URxvt.perl-ext-common: default,font-size
48 URxvt.urgentOnBell: true
49
50 !URxvt.urlLauncher: elinks
51 !URxvt*font: xft:DejaVu Sans Mono:pixelsize=9:antialias=true
52 !URxvt*font: xft:DejaVu Sans Mono:size=6.38:weight=medium:antialias=true:hintstyle=100:autohint=0,xft:unifont,xft:freemono:pixelsize=13,xft:Code2000:antialias=false
53 !URxvt*font: xft:DejaVu Sans Mono:pixelsize=24
54 !URxvt*font: xft:Inconsolata:pixelsize=10
55 !URxvt*font: xft:Fira Code:pixelsize=10
56 !URxvt*scrollWithBuffer: true
57 !: hinting=true:slant=0:weight=50
58 !URxvt*boldFont: xft:DejaVu Sans Mono:bold:pixelsize=9:antialias=true:hinting=true
59 !urxvt*boldColors: on
60 ! Allow switching of font sizes
61 !URxvt.keysym.C-M-minus: command:\033]710;xft:Terminus-8:slant=0:weight=80,xft:DejaVu\ Sans\ Mono-9:slant=0:weight=80,xft:Inconsolata-10,x:-schumacher-clean-medium-r-normal-*-12-*-*-*-c-*-iso10646-1,x:-misc-fixed-medium-r-semicondensed-*-13-*-*-*-c-*-iso10646-1,x:-b&h-lucidatypewriter-medium-r-normal-*-12-*-*-*-m-*-iso10646-1\007\033]711;xft:Terminus-8:slant=0:weight=200,xft:DejaVu\ Sans\ Mono-9:slant=0:weight=200,x:-misc-fixed-bold-r-semicondensed-*-13-*-*-*-c-*-iso10646-1,x:-b&h-lucidatypewriter-bold-r-normal-*-12-*-*-*-m-*-iso10646-1\007\033]712;xft:Terminus-8:slant=110:weight=80,xft:DejaVu Sans Mono-8:slant=110:weight=80\007\033]713;xft:Terminus-8:slant=110:weight=200,xft:DejaVu Sans Mono-8:slant=110:weight=200\007
62 !URxvt.keysym.C-M-equal: command:\033]710;xft:Terminus-14:slant=0:weight=80,xft:DejaVu\ Sans\ Mono-14:slant=0:weight=80,xft:Inconsolata-16,x:-gnu-unifont-medium-r-normal-*-17-*-*-*-c-*-iso10646-1,x:-b&h-lucidatypewriter-medium-r-normal-*-17-*-*-*-m-*-iso10646-1\007\033]711;xft:Terminus-14:slant=0:weight=200,xft:DejaVu\ Sans\ Mono-14:slant=0:weight=200,x:-misc-fixed-medium-r-normal-*-20-*-*-*-c-*-iso10646-1,x:-b&h-lucidatypewriter-*-r-normal-*-17-*-*-*-m-*-iso10646-1\007\033]712;xft:Terminus-14:slant=110:weight=80,xft:DejaVu Sans Mono-14:slant=110:weigth=80\007\033]713;xft:Terminus-14:slant=110:weight=200,xft:DejaVu Sans Mono-14:slant=110:weight=200\007
63 !URxvt.iso14755: False
64 !URxvt.perl-ext-common: default,matcher
65 '';
66 }