]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/bash.nix
bash: add tmux aliases
[julm/julm-nix.git] / home-manager / profiles / bash.nix
1 { pkgs, lib, ... }:
2 with lib;
3 {
4 programs.bash = {
5 enable = mkDefault true;
6 shellAliases = {
7 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
8 c = "bat";
9 cl = "clear";
10 eic = "edit-in-commit";
11 eigg = "edit-in-git-grep";
12 emacs = "emacsclient --create-frame";
13 g = "git";
14 gg = "git grep";
15 grep = "grep --color";
16 j = "sudo journalctl -u";
17 jb = "sudo journalctl -b";
18 ju = "sudo journalctl --user -u";
19 l = "ls -alh";
20 ll = "ls -al";
21 ls = "ls --color=tty";
22 md-toc = "grep '^#\\+' --color";
23 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
24 mem-top = "smem --sort rss --autosize";
25 mpl = "mplayer";
26 nf = "sudo nft list ruleset | less";
27 nix-du-svg = "nix-du | dot -Tsvg >nix-du.svg";
28 nixos-clean = "sudo nix-collect-garbage -d";
29 nixos-history = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
30 nixos-rollback = "sudo nixos-rebuild switch --rollback";
31 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
32 r = "reset";
33 rot13 = "tr A-Za-z N-ZA-Mn-za-m";
34 rot135 = "tr A-Za-z0-9 N-ZA-Mn-za-m5-90-4";
35 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
36 s = "sudo systemctl";
37 st = "sudo systemctl status";
38 t = "tmux";
39 t0 = "tmux new -t 0";
40 t1 = "tmux new -t 1";
41 t2 = "tmux new -t 2";
42 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
43 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
44 u = "systemctl --user";
45 ut = "systemctl --user status";
46 w1 = "watch --color --differences --interval 1";
47 w5 = "watch --color --differences --interval 5";
48 w10 = "watch --color --differences --interval 10";
49 w = "watch --color --differences";
50 watch = "watch --color --differences";
51 zfs-umount = "zfs-unmount";
52 };
53 sessionVariables = {
54 HISTCONTROL = "erasedups:ignorespace";
55 HISTSIZE = "42000";
56 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
57 };
58 initExtra = ''
59 # Alias completion
60 . ${pkgs.complete-alias}/bin/complete_alias
61 complete -F _complete_alias "''${!BASH_ALIASES[@]}"
62
63 shopt -s globstar
64 shopt -s histappend
65 shopt -s histreedit
66 shopt -s histverify
67 # Disable ctrl-s/ctrl-q flow control
68 stty -ixon
69
70 ffmpeg-audio () {
71 for i in "$@"; do
72 ffmpeg -i "$i" -vn -map 0:a -acodec copy "''${i%.*}".audio
73 done
74 }
75 ffmpeg-opus () {
76 for i in "$@"; do
77 ffmpeg -i "$i" -vn -map 0:a -c:a libopus -b:a 64k -application voip "''${i%.*}".opus
78 done
79 }
80 ibm-fan () {
81 if [ $# -gt 0 ]
82 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
83 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
84 fi
85 acpi -t
86 }
87 mkcd () {
88 mkdir -p "$1" &&
89 cd "$1"
90 }
91 mkpass () {
92 tr -d -C 'A-Za-z0-9' </dev/urandom | head -c 25 | xclip
93 }
94 opusenc-voice () {
95 find "$@" -depth -type f -print0 | sort -n -z |
96 xargs -0 -P "$(lscpu --online -p | grep -v "#" | wc -l)" -I {} bash -c '
97 test -e "''${0%.*}".opus ||
98 nice -n 19 ffmpeg -y -i "$0" -map 0:a -b:a 32k -application voip "''${0%.*}".opus
99 ' {} \;
100 }
101 smartctl-tbw () {
102 device=''${1:-/dev/sda}
103 sudo smartctl -A $device |
104 { awk '
105 $0 ~ /Power_On_Hours/ { poh=$10; printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25 }
106 $0 ~ /Total_LBAs_Written/ {
107 lbas = $10;
108 bytes = $10 * 512;
109 mb = bytes / 1024^2;
110 gb = bytes / 1024^3;
111 tb = bytes / 1024^4;
112 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
113 printf "mean writes per hour: / %.2f", mb/poh
114 }
115 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
116 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
117 '; echo; } |
118 sed -e 's:/:@:' |
119 sed -e "s\$^\$$device @ \$" |
120 column -ts@
121 }
122 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk "/MemAvailable/{ printf \"%d\n\", \$2 * $fac; }" </proc/meminfo)k; }
123 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
124 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
125 swaplist () {
126 lastpid=
127 swap=0
128 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
129 while IFS=: read -r file x size x
130 do
131 pid=''${file#/proc/}
132 pid=''${pid%/smaps}
133 size=''${size% kB}
134 size=''${size##* }
135 if test "$pid" = "$lastpid"
136 then swap=$(( swap + size ))
137 else
138 if test "$swap" -gt 0
139 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
140 fi
141 if test "$pid" = self
142 then break
143 else
144 lastpid=$pid
145 swap=$size
146 fi
147 fi
148 done |
149 sort -nk1,1
150 }
151 edit-in-commit () { $EDITOR $(git diff-tree --no-commit-id --name-only -r "$@"); }
152 edit-in-git-grep () { $EDITOR $(git grep --name-only --recursive "$@"); }
153
154 # Recursively mount not-mounted dataset,
155 # loading their keys if needed.
156 zfs-mount () {
157 local d
158 for d in $(zfs list -rH -o name "$@"); do
159 mountpoint /mnt/"$d" 2>/dev/null ||
160 sudo zfs mount -l "$d"
161 done
162 }
163 # Recursively unmount dataset,
164 # unloading their keys.
165 zfs-unmount () { sudo zfs unmount -u "$@"; }
166
167 # Restore the inheritance of encryptionroot,
168 # usually broken by zfs send --raw.
169 # Note that it needs to decrypt the datasets.
170 zfs-fix-encryptionroot () {
171 local d
172 zfs load-key "$1"
173 for d in $(zfs list -rHo name "$1" | tail -n +2); do
174 echo >&2 "$d"
175 test "$(zfs get -Ho value encryptionroot $d)" = "$1" ||
176 zfs change-key -li "$d"
177 done
178 }
179
180 # Recursively remove all the snapshots of given datasets
181 zfs-destroy-snapshots () {
182 local d
183 for d in "$@"; do
184 zfs list -t snapshot -rHo name "$d" |
185 xargs --no-run-if-empty -L1 zfs destroy
186 done
187 }
188 '';
189 profileExtra = ''
190 '';
191 };
192 programs.direnv.enableBashIntegration = true;
193 #programs.broot.enableBashIntegration = true;
194 programs.readline = {
195 enable = mkDefault true;
196 includeSystemConfig = true;
197 bindings = {
198 # Up/Down
199 "\\e[A" = "history-search-backward";
200 "\\e[B" = "history-search-forward";
201 "\\eOA" = "history-search-backward";
202 "\\eOB" = "history-search-forward";
203
204 # Ctrl-Left/Ctrl-Right
205 "\\e[1;5C" = "forward-word";
206 "\\e[1;5D" = "backward-word";
207 "\\e[5C" = "forward-word";
208 "\\e[5D" = "backward-word";
209 "\\e\\e[C" = "forward-word";
210 "\\e\\e[D" = "backward-word";
211
212 # Home/End
213 "\\e[1~" = "beginning-of-line";
214 "\\e[4~" = "end-of-line";
215
216 # Delete/Insert
217 "\\e[3~" = "delete-char";
218 "\\e[2~" = "quoted-insert";
219
220 # For non RH/Debian xterm, can't hurt for RH/Debian xterm
221 "\\eOF" = "end-of-line";
222 "\\eOH" = "beginning-of-line";
223
224 # For freebsd console
225 "\\e[F" = "end-of-line";
226 "\\e[H" = "beginning-of-line";
227
228 # $if term=rxvt
229 "\\e[7~" = "beginning-of-line";
230 "\\e[8~" = "end-of-line";
231 "\\eOc" = "forward-word";
232 "\\eOd" = "backward-word";
233 # $endif
234 };
235 variables = {
236 # Be 8 bit clean.
237 input-meta = mkDefault true;
238 output-meta = mkDefault true;
239 colored-completion-prefix = mkDefault true;
240 colored-stats = mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
241 echo-control-characters = mkDefault true;
242 mark-symlinked-directories = mkDefault true;
243 menu-complete-display-prefix = mkDefault true;
244 show-all-if-ambiguous = mkDefault true;
245 show-all-if-unmodified = mkDefault true;
246 visible-stats = mkDefault false; # Append char to indicate type
247 enable-bracketed-paste = mkDefault true;
248 };
249 };
250 }