7 # error: phantomjs 1.9.8 has been dropped due to lack of maintenance and security issues
11 xdg.configFile."yt-dlp/config".text = ''
12 #--download-archive .downloaded
16 --format ${lib.concatStringsSep "/" [
17 "bestvideo[height=480][ext=mp4]+bestaudio"
18 "bestvideo[height=480]+bestaudio"
19 "bestvideo[height<=480][ext=mp4]+bestaudio"
20 "bestvideo[height<=480]+bestaudio"
21 "best[height=480][ext=mp4]"
23 "best[height<=480][ext=mp4]"
27 --output "%(release_date>%Y-%m-%d,upload_date>%Y-%m-%d)s - %(title)s.%(id)s.%(format_id)s.%(ext)s"
28 --match-filter !is_live
30 --sub-format ass/srt/best
31 --sub-langs "en.*,fr,-live_chat"
32 --user-agent Mozilla/5.0