1 { config, pkgs, lib, inputs, ... }:
4 ../nixos/profiles/server.nix
5 #../nixos/profiles/debug.nix
6 ../nixos/profiles/lang-fr.nix
7 #../nixos/profiles/tor.nix
9 aubergine/networking.nix
15 # Lower kernel's security for better performances
16 boot.kernelParams = [ "mitigations=off" ];
18 home-manager.users.julm = {
19 imports = [ ../homes/julm.nix ];
25 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
26 # which is already world readable.
27 # printf %s $(mkpasswd -m yescrypt)
28 hashedPassword = lib.readFile aubergine/users/julm/login/hashedPassword.clear;
36 # If created, zfs-mount.service would require:
37 # zfs set overlay=yes ${hostName}/home
39 openssh.authorizedKeys.keys = map lib.readFile [
40 ../users/root/ssh/losurdo.pub
41 ../users/julm/ssh/losurdo.pub
42 ../users/julm/ssh/oignon.pub
43 ../users/julm/ssh/redmi.pub
48 openssh.authorizedKeys.keys =
49 config.users.users.julm.openssh.authorizedKeys.keys;
57 # If created, zfs-mount.service would require:
58 # zfs set overlay=yes ${hostName}/home
60 openssh.authorizedKeys.keys = map lib.readFile [
61 ../users/sevy/ssh/patate.pub
66 #systemd.services.nix-daemon.serviceConfig.LoadCredentialEncrypted =
67 # "secret-key-files:" + aubergine/nix/secret-key-files;
70 #secret-key-files = /run/credentials/nix-daemon.service/secret-key-files.pem
74 #"http://nix-localcache.losurdo.wg"
75 #"ssh://nix-ssh@losurdo.wg?priority=30"
76 #"ssh://nix-ssh@oignon.wg?priority=30"
78 trusted-public-keys = map lib.readFile [
79 ../users/root/nix/oignon.pub
82 nixPath = lib.mkForce [ "nixpkgs=${inputs.nixpkgs}" ];
84 #environment.etc."nixpkgs".source = pkgs.path;
85 #environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
87 nix.settings.allowed-users = [ config.users.users."nix-ssh".name ];
90 keys = map lib.readFile [
91 ../users/julm/ssh/losurdo.pub
92 ../users/sevy/ssh/patate.pub
93 ../users/julm/ssh/oignon.pub
97 environment.systemPackages = [
100 boot.extraModulePackages = [
101 #config.boot.kernelPackages.v4l2loopback
104 # This value determines the NixOS release with which your system is to be
105 # compatible, in order to avoid breaking some software such as database
106 # servers. You should change this only after NixOS release notes say you should.
107 system.stateVersion = "22.11"; # Did you read the comment?