1 { config, pkgs, lib, inputs, hostName, ... }:
4 ../nixos/profiles/graphical.nix
5 ../nixos/profiles/lang-fr.nix
6 ../nixos/profiles/printing.nix
12 # Lower kernel's security for better performances
13 boot.kernelParams = [ "mitigations=off" ];
15 home-manager.users.mo = {
16 imports = [ ../homes/mo.nix ];
19 openssh.authorizedKeys.keys = map lib.readFile [
20 ../users/julm/ssh/oignon.pub
21 ../users/julm/ssh/losurdo.pub
27 # Put the hashedPassword in /nix/store,
28 # though /etc/shadow is not world readable...
29 # printf %s $(mkpasswd -m yescrypt)
30 hashedPassword = lib.readFile courge/users/mo/login/hashedPassword.clear;
36 #"plugdev" # For rtl-sdr
42 #config.services.davfs2.davGroup
45 # If created, zfs-mount.service would require:
46 # zfs set overlay=yes ${hostName}/home
48 openssh.authorizedKeys.keys = map lib.readFile [
49 ../users/julm/ssh/oignon.pub
50 ../users/julm/ssh/losurdo.pub
54 environment.systemPackages = [
55 #pkgs.riseup-vpn # Can't be installed by home-manager because it needs to install policy-kit rules
58 boot.extraModulePackages = [
61 #programs.fuse.userAllowOther = true;
68 defaultSession = "gnome";
71 user = config.users.users.mo.name;
76 # This value determines the NixOS release with which your system is to be
77 # compatible, in order to avoid breaking some software such as database
78 # servers. You should change this only after NixOS release notes say you should.
79 system.stateVersion = "23.05"; # Did you read the comment?