]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/bash.nix
bash: add shellAliases.afk
[julm/julm-nix.git] / home-manager / profiles / bash.nix
1 { pkgs, lib, ... }:
2 with lib;
3 {
4 programs.bash = {
5 enable = mkDefault true;
6 shellAliases = {
7 afk = "xset s activate dpms force off";
8 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
9 c = "bat";
10 cl = "clear";
11 eic = "edit-in-commit";
12 eigg = "edit-in-git-grep";
13 emacs = "emacsclient --create-frame";
14 g = "git";
15 gg = "git grep";
16 grep = "grep --color";
17 j = "sudo journalctl -u";
18 jb = "sudo journalctl -b";
19 ju = "sudo journalctl --user -u";
20 l = "ls -alh";
21 ll = "ls -al";
22 ls = "ls --color=tty";
23 md-toc = "grep '^#\\+' --color";
24 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
25 mem-top = "smem --sort rss --autosize";
26 mpl = "mplayer";
27 nf = "sudo nft list ruleset | less";
28 nix-du-svg = "nix-du | dot -Tsvg >nix-du.svg";
29 nixos-clean = "sudo nix-collect-garbage -d";
30 nixos-history = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
31 nixos-rollback = "sudo nixos-rebuild switch --rollback";
32 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
33 r = "reset";
34 rot13 = "tr A-Za-z N-ZA-Mn-za-m";
35 rot135 = "tr A-Za-z0-9 N-ZA-Mn-za-m5-90-4";
36 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
37 s = "sudo systemctl";
38 st = "sudo systemctl status";
39 t = "tmux";
40 t0 = "tmux new -t 0";
41 t1 = "tmux new -t 1";
42 t2 = "tmux new -t 2";
43 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
44 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
45 u = "systemctl --user";
46 ut = "systemctl --user status";
47 w1 = "watch --color --differences --interval 1";
48 w5 = "watch --color --differences --interval 5";
49 w10 = "watch --color --differences --interval 10";
50 w = "watch --color --differences";
51 watch = "watch --color --differences";
52 zfs-umount = "zfs-unmount";
53 };
54 sessionVariables = {
55 HISTCONTROL = "erasedups:ignorespace";
56 HISTSIZE = "42000";
57 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
58 };
59 initExtra = ''
60 # Alias completion
61 . ${pkgs.complete-alias}/bin/complete_alias
62 complete -F _complete_alias "''${!BASH_ALIASES[@]}"
63
64 shopt -s globstar
65 shopt -s histappend
66 shopt -s histreedit
67 shopt -s histverify
68 # Disable ctrl-s/ctrl-q flow control
69 stty -ixon
70
71 ffmpeg-audio () {
72 for i in "$@"; do
73 ffmpeg -i "$i" -vn -map 0:a -acodec copy "''${i%.*}".audio
74 done
75 }
76 ffmpeg-opus () {
77 for i in "$@"; do
78 ffmpeg -i "$i" -vn -map 0:a -c:a libopus -b:a 64k -application voip "''${i%.*}".opus
79 done
80 }
81 ibm-fan () {
82 if [ $# -gt 0 ]
83 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
84 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
85 fi
86 acpi -t
87 }
88 mkcd () {
89 mkdir -p "$1" &&
90 cd "$1"
91 }
92 mkpass () {
93 tr -d -C 'A-Za-z0-9' </dev/urandom | head -c 25 | xclip
94 }
95 opusenc-voice () {
96 find "$@" -depth -type f -print0 | sort -n -z |
97 xargs -0 -P "$(lscpu --online -p | grep -v "#" | wc -l)" -I {} bash -c '
98 test -e "''${0%.*}".opus ||
99 nice -n 19 ffmpeg -y -i "$0" -map 0:a -b:a 32k -application voip "''${0%.*}".opus
100 ' {} \;
101 }
102 smartctl-tbw () {
103 device=''${1:-/dev/sda}
104 sudo smartctl -A $device |
105 { awk '
106 $0 ~ /Power_On_Hours/ { poh=$10; printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25 }
107 $0 ~ /Total_LBAs_Written/ {
108 lbas = $10;
109 bytes = $10 * 512;
110 mb = bytes / 1024^2;
111 gb = bytes / 1024^3;
112 tb = bytes / 1024^4;
113 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
114 printf "mean writes per hour: / %.2f", mb/poh
115 }
116 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
117 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
118 '; echo; } |
119 sed -e 's:/:@:' |
120 sed -e "s\$^\$$device @ \$" |
121 column -ts@
122 }
123 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk "/MemAvailable/{ printf \"%d\n\", \$2 * $fac; }" </proc/meminfo)k; }
124 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
125 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
126 swaplist () {
127 lastpid=
128 swap=0
129 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
130 while IFS=: read -r file x size x
131 do
132 pid=''${file#/proc/}
133 pid=''${pid%/smaps}
134 size=''${size% kB}
135 size=''${size##* }
136 if test "$pid" = "$lastpid"
137 then swap=$(( swap + size ))
138 else
139 if test "$swap" -gt 0
140 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
141 fi
142 if test "$pid" = self
143 then break
144 else
145 lastpid=$pid
146 swap=$size
147 fi
148 fi
149 done |
150 sort -nk1,1
151 }
152 edit-in-commit () { $EDITOR $(git diff-tree --no-commit-id --name-only -r "$@"); }
153 edit-in-git-grep () { $EDITOR $(git grep --name-only --recursive "$@"); }
154
155 # Recursively mount not-mounted dataset,
156 # loading their keys if needed.
157 zfs-mount () {
158 local d
159 local -
160 set -e
161 for d in $(zfs list -rH -o name "$@"); do
162 mountpoint /mnt/"$d" 2>/dev/null ||
163 sudo zfs mount -l "$d"
164 done
165 }
166 # Recursively unmount dataset,
167 # unloading their keys.
168 zfs-unmount () { sudo zfs unmount -u "$@"; }
169
170 # Restore the inheritance of encryptionroot,
171 # usually broken by zfs send --raw.
172 # Note that it needs to decrypt the datasets.
173 zfs-fix-encryptionroot () {
174 local d
175 zfs load-key "$1"
176 for d in $(zfs list -rHo name "$1" | tail -n +2); do
177 echo >&2 "$d"
178 test "$(zfs get -Ho value encryptionroot $d)" = "$1" ||
179 zfs change-key -li "$d"
180 done
181 }
182
183 # Recursively remove all the snapshots of given datasets
184 zfs-destroy-snapshots () {
185 local d
186 for d in "$@"; do
187 zfs list -t snapshot -rHo name "$d" |
188 xargs --no-run-if-empty -L1 zfs destroy
189 done
190 }
191 '';
192 profileExtra = ''
193 '';
194 };
195 programs.direnv.enableBashIntegration = true;
196 #programs.broot.enableBashIntegration = true;
197 programs.readline = {
198 enable = mkDefault true;
199 includeSystemConfig = true;
200 bindings = {
201 # Up/Down
202 "\\e[A" = "history-search-backward";
203 "\\e[B" = "history-search-forward";
204 "\\eOA" = "history-search-backward";
205 "\\eOB" = "history-search-forward";
206
207 # Ctrl-Left/Ctrl-Right
208 "\\e[1;5C" = "forward-word";
209 "\\e[1;5D" = "backward-word";
210 "\\e[5C" = "forward-word";
211 "\\e[5D" = "backward-word";
212 "\\e\\e[C" = "forward-word";
213 "\\e\\e[D" = "backward-word";
214
215 # Home/End
216 "\\e[1~" = "beginning-of-line";
217 "\\e[4~" = "end-of-line";
218
219 # Delete/Insert
220 "\\e[3~" = "delete-char";
221 "\\e[2~" = "quoted-insert";
222
223 # For non RH/Debian xterm, can't hurt for RH/Debian xterm
224 "\\eOF" = "end-of-line";
225 "\\eOH" = "beginning-of-line";
226
227 # For freebsd console
228 "\\e[F" = "end-of-line";
229 "\\e[H" = "beginning-of-line";
230
231 # $if term=rxvt
232 "\\e[7~" = "beginning-of-line";
233 "\\e[8~" = "end-of-line";
234 "\\eOc" = "forward-word";
235 "\\eOd" = "backward-word";
236 # $endif
237 };
238 variables = {
239 # Be 8 bit clean.
240 input-meta = mkDefault true;
241 output-meta = mkDefault true;
242 colored-completion-prefix = mkDefault true;
243 colored-stats = mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
244 echo-control-characters = mkDefault true;
245 mark-symlinked-directories = mkDefault true;
246 menu-complete-display-prefix = mkDefault true;
247 show-all-if-ambiguous = mkDefault true;
248 show-all-if-unmodified = mkDefault true;
249 visible-stats = mkDefault false; # Append char to indicate type
250 enable-bracketed-paste = mkDefault true;
251 };
252 };
253 }