]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/bash.nix
bash: add white-on-black and black-on-white
[julm/julm-nix.git] / home-manager / profiles / bash.nix
1 { pkgs, lib, config, ... }:
2 {
3 programs.bash = {
4 enable = lib.mkDefault true;
5 shellAliases = {
6 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
7 c = "bat";
8 cl = "clear";
9 eic = "edit-in-commit";
10 eigg = "edit-in-git-grep";
11 emacs = "emacsclient --create-frame";
12 g = "git";
13 gg = "git grep";
14 grep = "grep --color";
15 j="sudo journalctl -u";
16 jb="sudo journalctl -b";
17 l = "ls -alh";
18 ll = "ls -al";
19 ls = "ls --color=tty";
20 md-toc = "grep '^#\\+' --color";
21 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
22 mem-top = "smem --sort rss --autosize";
23 mpl = "mplayer";
24 nixos-clean="sudo nix-collect-garbage -d";
25 nixos-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
26 nixos-rollback="sudo nixos-rebuild switch --rollback";
27 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
28 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
29 s="sudo systemctl";
30 st="sudo systemctl status";
31 u="systemctl --user";
32 ut="systemctl --user status";
33 watch = "watch --color --differences";
34 white-on-black = "echo -e '\\033]11;white\\007\\033]10;black\\007'";
35 yt = "yt-dlp";
36 zfs-umount = "zfs-unmount";
37 };
38 initExtra = ''
39 shopt -s globstar
40 shopt -s histreedit
41 shopt -s histverify
42 # Disable ctrl-s/ctrl-q flow control
43 stty -ixon
44
45 ibm-fan () {
46 if [ $# -gt 0 ]
47 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
48 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
49 fi
50 acpi -t
51 }
52 mkcd () {
53 mkdir -p "$1" &&
54 cd "$1"
55 }
56 smartctl-tbw () {
57 device=''${1:-/dev/sda}
58 sudo smartctl -A $device |
59 { awk '
60 $0 ~ /Power_On_Hours/ { poh=$10; printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25 }
61 $0 ~ /Total_LBAs_Written/ {
62 lbas = $10;
63 bytes = $10 * 512;
64 mb = bytes / 1024^2;
65 gb = bytes / 1024^3;
66 tb = bytes / 1024^4;
67 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
68 printf "mean writes per hour: / %.2f", mb/poh
69 }
70 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
71 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
72 '; echo; } |
73 sed -e 's:/:@:' |
74 sed -e "s\$^\$$device @ \$" |
75 column -ts@
76 }
77 swaplist () {
78 lastpid=
79 swap=0
80 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
81 while IFS=: read -r file x size x
82 do
83 pid=''${file#/proc/}
84 pid=''${pid%/smaps}
85 size=''${size% kB}
86 size=''${size##* }
87 if test "$pid" = "$lastpid"
88 then swap=$(( swap + size ))
89 else
90 if test "$swap" -gt 0
91 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
92 fi
93 if test "$pid" = self
94 then break
95 else
96 lastpid=$pid
97 swap=$size
98 fi
99 fi
100 done |
101 sort -nk1,1
102 }
103 edit-in-commit () { $EDITOR $(git diff-tree --no-commit-id --name-only -r "$@"); }
104 edit-in-git-grep () { $EDITOR $(git grep --name-only --recursive "$@"); }
105 zfs-mount () { for d in $(zfs list -rH -o name "$@"); do sudo zfs mount -l "$d"; done; }
106 zfs-unmount () { sudo zfs unmount -u "$@"; }
107 '';
108 profileExtra = ''
109 '';
110 };
111 programs.direnv.enableBashIntegration = true;
112 #programs.broot.enableBashIntegration = true;
113 home.sessionVariables = {
114 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
115 };
116 programs.readline = {
117 enable = lib.mkDefault true;
118 includeSystemConfig = true;
119 bindings = {
120 "\\eOF" = "end-of-line";
121 "\\eOH" = "beginning-of-line";
122 "\\e[1;5C" = "forward-word";
123 "\\e[1;5D" = "backward-word";
124 "\\e[1~" = "beginning-of-line";
125 "\\e[4~" = "end-of-line";
126 "\\e[5C" = "forward-word";
127 "\\e[5D" = "backward-word";
128 "\\e[7~" = "beginning-of-line";
129 "\\e[8~" = "end-of-line";
130 "\\e[A" = "history-search-backward";
131 "\\e[B" = "history-search-forward";
132 "\\e[F" = "end-of-line";
133 "\\e[H" = "beginning-of-line";
134 "\\e\\e[C" = "forward-word";
135 "\\e\\e[D" = "backward-word";
136 };
137 variables = {
138 colored-completion-prefix = lib.mkDefault true;
139 colored-stats = lib.mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
140 echo-control-characters = lib.mkDefault true;
141 mark-symlinked-directories = lib.mkDefault true;
142 menu-complete-display-prefix = lib.mkDefault true;
143 show-all-if-ambiguous = lib.mkDefault true;
144 show-all-if-unmodified = lib.mkDefault true;
145 visible-stats = lib.mkDefault false; # Append char to indicate type
146 };
147 };
148 }