11 ../nixos/profiles/debug.nix
12 ../nixos/profiles/graphical.nix
13 ../nixos/profiles/irssi.nix
14 ../nixos/profiles/lang-fr.nix
15 ../nixos/profiles/laptop.nix
16 ../nixos/profiles/printing.nix
17 ../nixos/profiles/radio.nix
18 ../nixos/profiles/tor.nix
19 ../nixos/profiles/bluetooth.nix
20 ../nixos/profiles/home.nix
25 pumpkin/networking.nix
28 # Lower kernel's security for better performances
29 security.kernel.mitigations = "off";
31 home-manager.users.julm = {
32 imports = [ ../homes/julm.nix ];
35 openssh.authorizedKeys.keys = map lib.readFile [
36 # For nix -L run .#pumpkin.switch
37 ../users/julm/ssh/pumpkin.pub
43 # Put the hashedPassword in /nix/store,
44 # though /etc/shadow is not world readable...
45 # printf %s $(mkpasswd -m md5crypt)
46 hashedPassword = lib.readFile pumpkin/users/julm/login/hashedPassword.clear;
52 "plugdev" # For rtl-sdr
59 config.services.davfs2.davGroup
62 # If created, zfs-mount.service would require:
63 # zfs set overlay=yes ${hostName}/home
65 openssh.authorizedKeys.keys = map lib.readFile [
66 ../users/julm/ssh/losurdo.pub
73 #"http://nix-localcache.losurdo.sp"
74 #"file:///mnt/off4/julm/nix?priority=10&trusted=true"
75 "ssh://nix-ssh@losurdo.sp?priority=30"
77 trusted-public-keys = map lib.readFile [
78 ../users/nix/ssh/losurdo.pub
81 nixPath = lib.mkForce [ "nixpkgs=${inputs.nixpkgs}" ];
83 #environment.etc."nixpkgs".source = pkgs.path;
84 #environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
86 nix.settings.allowed-users = [
87 #config.users.users."nix-ssh".name
91 keys = map lib.readFile [
92 ../users/julm/ssh/losurdo.pub
93 ../users/julm/ssh/pumpkin.pub
94 ../users/sevy/ssh/patate.pub
98 environment.systemPackages = [
99 #pkgs.riseup-vpn # Can't be installed by home-manager because it needs to install policy-kit rules
102 boot.extraModulePackages = [
103 #config.boot.kernelPackages.v4l2loopback
106 programs.adb.enable = true;
108 programs.fuse.userAllowOther = true;
110 services.davfs2.enable = true;
112 systemd.automounts = [
114 where = "/mnt/aubergine";
115 automountConfig.TimeoutIdleSec = "5 min";
120 # Use the user's gpg-agent session to query
121 # for the password of the SSH key when auto-mounting.
122 sshAsUser = pkgs.writeScript "sshAsUser" ''
124 exec ${pkgs.sudo}/bin/sudo -i -u "$user" \
125 ${pkgs.openssh}/bin/ssh "$@"
132 "exec" # Override "user"'s noexec
136 "ssh_command=${sshAsUser}\\040julm"
139 "x-systemd.automount"
140 #"Compression=yes" # YMMV
141 # Disconnect approximately 2*15=30 seconds after a network failure
142 "ServerAliveCountMax=1"
143 "ServerAliveInterval=15"
150 device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@aubergine.sp:/";
155 device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@losurdo.sp:/";
160 device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@mermet.sp:/";
165 "/mnt/ilico/severine" = {
166 device = "https://nuage.ilico.org/remote.php/dav/files/severine/";
170 conf = pkgs.writeText "davfs2.conf" ''
171 backup_dir /home/julm/.local/share/davfs2/ilico/severine
172 secrets /home/julm/.davfs2/secrets
184 "x-systemd.automount"
185 "x-systemd.device-timeout=1m"
186 "x-systemd.idle-timeout=1m"
187 "x-systemd.mount-timeout=10s"
195 defaultMode = "online";
198 localDiscovery = false;
200 Datastore.StorageMax = "10GB";
201 Discovery.MDNS.Enabled = false;
204 #Swarm.AddrFilters = null;
206 startWhenNeeded = true;
209 services.udev.packages = [
210 # Allow the console user access the Yubikey USB device node,
211 # needed for challenge/response to work correctly.
212 pkgs.yubikey-personalization
217 layout = "fr,us(altgr-intl)";
221 # Let the session be generated by home-manager
223 name = "home-manager";
225 ${pkgs.runtimeShell} $HOME/.hm-xsession &
233 services.displayManager = {
234 defaultSession = "home-manager";
235 #defaultSession = "none+xmonad";
236 #defaultSession = "mate";
237 #defaultSession = "cinnamon";
239 user = config.users.users.julm.name;
243 nixpkgs.config.allowUnfreePredicate =
245 builtins.elem (lib.getName pkg) [
253 # This value determines the NixOS release with which your system is to be
254 # compatible, in order to avoid breaking some software such as database
255 # servers. You should change this only after NixOS release notes say you should.
256 system.stateVersion = "24.11"; # Did you read the comment?