]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/courge/backup.nix
courge: sanoid: setup
[julm/julm-nix.git] / hosts / courge / backup.nix
1 { pkgs, lib, hostName, ... }:
2 with builtins;
3 {
4 services.sanoid = {
5 enable = true;
6 extraArgs = [ "--verbose" ];
7 datasets = {
8 "${hostName}/root/home/mo" = {
9 autosnap = true;
10 autoprune = true;
11 hourly = 0;
12 daily = 15;
13 monthly = 0;
14 yearly = 0;
15 recursive = true;
16 };
17 "${hostName}/root/home/mo/.cache" = {
18 autosnap = false;
19 };
20 "${hostName}/root/home/mo/Documents" = {
21 autosnap = true;
22 autoprune = true;
23 hourly = 12;
24 daily = 31;
25 };
26 "${hostName}/root/home/mo/Telechargements" = {
27 autosnap = false;
28 };
29 };
30 };
31 }