1 { pkgs, lib, config, ... }:
3 home.file.".xmonad/xmobar.hs".source = xmonad/xmobar.hs;
6 scriptPath = ".hm-xsession";
9 ${pkgs.xorg.xsetroot}/bin/xsetroot -solid black -fg black -bg white -cursor_name left_ptr
10 ${pkgs.rxvt-unicode}/bin/urxvtd -f -o
11 ${pkgs.copyq}/bin/copyq &
12 ${pkgs.pasystray}/bin/pasystray &
14 windowManager.xmonad = {
16 haskellPackages = pkgs.haskellPackages;
17 extraPackages = haskellPackages: [
18 haskellPackages.data-default
20 enableContribAndExtras = true;
21 config = xmonad/xmonad.hs;
27 pkgs.ffmpegthumbnailer
30 pkgs.mate.caja-with-extensions
31 (pkgs.writeShellScriptBin "mate-terminal" ''exec ${pkgs.rxvt-unicode}/bin/urxvtc -hold "$@"'')
42 xresources.properties = {
43 "Xft.antialias" = true;
45 "Xft.hintstyle" = "hintfull";
47 #"Xft.embolden" = true;