1 { pkgs, lib, config, hostName, credentials, ... }:
4 peers = import wg-intra/peers.nix;
5 wg = config.networking.wireguard.interfaces.${wgIface};
8 # Each peer select the other peers allowed to connect to it
9 options.networking.wireguard.${wgIface}.peers =
10 lib.genAttrs (lib.attrNames peers) (peerName: {
11 enable = lib.mkEnableOption "this peer";
14 systemd.services."wireguard-${wgIface}".serviceConfig.LoadCredentialEncrypted = "privateKey:${credentials}/wireguard/${wgIface}/privateKey.secret";
15 networking.wireguard.interfaces.${wgIface} = lib.recursiveUpdate
16 (removeAttrs peers.${hostName} ["ipv4" "persistentKeepalive" "peer"])
19 lib.mapAttrsToList (peerName: peer:
23 peer.persistentKeepalive # Useful if this peer is behind a NAT
24 or peers.${hostName}.persistentKeepalive # Useful if this host is behind a NAT
29 (lib.filterAttrs (peerName: _: config.networking.wireguard.${wgIface}.peers.${peerName}.enable) peers)
31 privateKeyFile = "$CREDENTIALS_DIRECTORY/privateKey";
33 # Set the MTU to a minimum
34 # (IPv4 requires at least 68 but it's 1280 for IPv6).
35 # This prevents connections to stall on huge packets,
36 # or delaying their initializing due to TCP PMTU probing.
38 ip link set dev ${wgIface} mtu 1280
41 networking.hosts = lib.mkMerge [
42 (lib.mapAttrs' (hostName: host:
43 lib.nameValuePair host.ipv4 [ "${hostName}.wg" ]) peers)
45 "${peers.losurdo.ipv4}" = [
46 "nix-extracache.losurdo.wg"
47 "nix-localcache.losurdo.wg"
52 networking.firewall.extraCommands = lib.optionalString (wg.listenPort != null) ''
53 ip46tables -A nixos-fw -i any -p udp -m udp --dport ${toString wg.listenPort} -j ACCEPT
56 networking.nftables.ruleset = lib.optionalString (wg.listenPort != null) ''
59 udp dport ${toString wg.listenPort} counter accept comment "Wireguard ${wgIface} input from peers"
62 udp dport ${toString wg.listenPort} counter accept comment "Wireguard ${wgIface} input from peers"
65 ${lib.optionalString (peers.${hostName}.peer.endpointsUpdater.enable or false) ''
66 tcp dport ${toString peers.${hostName}.listenPort} ip daddr ${peers.${hostName}.ipv4} counter accept comment "Wireguard ${wgIface} from peers to endpointUpdater"
71 iifname ${wgIface} jump input-intra
72 iifname ${wgIface} log level warn prefix "input-intra: " counter drop
76 udp sport ${toString wg.listenPort} counter accept comment "Wireguard ${wgIface} output to peers"
79 udp sport ${toString wg.listenPort} counter accept comment "Wireguard ${wgIface} output to peers"
82 ${lib.concatStringsSep "\n"
83 (lib.mapAttrsToList (peerName: peer: ''
84 tcp dport ${toString peer.listenPort} ip daddr ${peer.ipv4} counter accept comment "Wireguard ${wgIface} to endpointUpdater ${peerName}"
86 (lib.filterAttrs (peerName: peer:
87 config.networking.wireguard.${wgIface}.peers.${peerName}.enable &&
88 (peers.${peerName}.peer.endpointsUpdater.enable or false))
93 oifname ${wgIface} jump output-intra
94 oifname ${wgIface} log level warn prefix "output-intra: " counter drop
99 services.fail2ban.ignoreIP = lib.concatMap
100 (host: host.peer.allowedIPs)
101 (lib.attrValues peers);
102 networking.networkmanager.unmanaged = [ wgIface ];
103 systemd.services.sshd.after = ["wireguard-${wgIface}.service"];