13 xdg.configFile."xmonad/xmobar0.hs".force = true;
14 xdg.configFile."xmonad/xmobar0.hs".source = xmonad/xmobar0.hs;
15 home.file.".xmonad/xmonad.hs".force = true;
16 home.file.".xmonad/xmonad-${pkgs.stdenv.hostPlatform.system}".force = true;
19 scriptPath = ".hm-xsession";
21 xset dpms 380 640 1200
22 ${pkgs.xorg.xsetroot}/bin/xsetroot -solid black -fg black -bg white -cursor_name left_ptr
23 ${pkgs.pasystray}/bin/pasystray &
25 windowManager.xmonad = {
27 inherit (pkgs) haskellPackages;
28 extraPackages = haskellPackages: [
29 haskellPackages.data-default
31 enableContribAndExtras = true;
33 # nix shell --impure --expr 'with import <nixpkgs> {}; haskellPackages.ghcWithPackages (hs: with hs; [ xmonad-contrib data-default ])'
34 # ln -fns $PWD/home-manager/profiles/xmonad/xmonad.hs ~/.xmonad/xmonad.hs
35 # ~/.xmonad/xmonad-x86_64-linux --recompile && ~/.xmonad/xmonad-x86_64-linux --restart
36 config = xmonad/xmonad.hs;
42 pkgs.ffmpegthumbnailer
47 pkgs.mate.caja-with-extensions
48 #(pkgs.writeShellScriptBin "mate-terminal" ''exec ${pkgs.rxvt-unicode}/bin/urxvtc -hold "$@"'')
62 xresources.properties = {
63 "Xft.antialias" = true;
65 "Xft.hintstyle" = "hintfull";
67 #"Xft.embolden" = true;