1 { config, pkgs, inputs, machineName, ... }:
3 inherit (config.users) users;
10 users.mutableUsers = false;
14 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
15 # which is already world readable.
16 hashedPassword = builtins.readFile ../secrets/julm/hashedPassword;
22 # If created, zfs-mount.service would require:
23 # zfs set overlay=yes ${machineName}/home
29 auto-optimise-store = true
34 options = "--delete-older-than 7d";
37 "nixpkgs=/etc/nixpkgs"
38 "nixpkgs-overlays=/etc/nixpkgs-overlays/overlays.nix"
40 trustedUsers = [ users.julm.name ];
42 environment.etc."nixpkgs".source = pkgs.path;
43 environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
49 time.timeZone = "Europe/Paris";
50 i18n.defaultLocale = "fr_FR.UTF-8";
51 console.font = "Lat2-Terminus16";
52 console.keyMap = "fr";
55 hostName = machineName;
56 domain = "localdomain";
63 #backend = "wpa_supplicant";
73 hardware.pulseaudio.enable = true;
75 environment.variables = {
78 SYSTEMD_LESS = "FKMRX";
80 environment.systemPackages = with pkgs; [
130 interactiveShellInit = ''
131 bind '"\e[A":history-search-backward'
132 bind '"\e[B":history-search-forward'
134 # Ignore duplicate commands, ignore commands starting with a space
135 export HISTCONTROL=erasedups:ignorespace
136 export HISTSIZE=42000
137 # Append to the history instead of overwriting (good for multiple connections)
144 ls = "ls --color=tty";
145 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
148 st="sudo systemctl status";
149 s-u="systemctl --user";
150 j="sudo journalctl -u";
152 nix-clean="sudo nix-collect-garbage -d";
153 nix-catalog="sudo nix-channel --list";
154 nix-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
155 nix-rollback="sudo nixos-rebuild switch --rollback";
156 nix-update="sudo nix-channel --update";
157 nix-upgrade="sudo nixos-rebuild switch";
158 nix-upstream="sudo nix-channel --list";
159 nix-config="gvim ~/.config/nixos/*.nix";
165 enableSSHSupport = true;
176 packages = [ pkgs.gnome3.dconf ];
184 MaxRetentionSec=1month
192 # NOTE: xfconf-query -c xfce4-session -p /general/LockCommand -s "physlock" --create -t string
203 extraArgs = [ "--verbose" ];
205 "${machineName}/home" = {
214 "${machineName}/var" = {
228 xkbOptions = "eurosign:e";
229 libinput.enable = true;
232 # Let the session be generated by home-manager
233 { name = "home-manager";
235 ${pkgs.runtimeShell} $HOME/.hm-xsession &
244 pkgs.xfce.thunar-archive-plugin
248 xterm.enable = false;
251 defaultSession = "home-manager";
252 #defaultSession = "none+xmonad";
255 user = users.julm.name;
261 #virtualisation.virtualbox.host.enable = true;
263 # This value determines the NixOS release with which your system is to be
264 # compatible, in order to avoid breaking some software such as database
265 # servers. You should change this only after NixOS release notes say you should.
266 system.stateVersion = "20.09"; # Did you read the comment?