]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/bash.nix
bash: add zfs-fix-encryptionroot
[julm/julm-nix.git] / home-manager / profiles / bash.nix
1 { pkgs, lib, ... }:
2 with lib;
3 {
4 programs.bash = {
5 enable = mkDefault true;
6 shellAliases = {
7 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
8 c = "bat";
9 cl = "clear";
10 eic = "edit-in-commit";
11 eigg = "edit-in-git-grep";
12 emacs = "emacsclient --create-frame";
13 g = "git";
14 gg = "git grep";
15 grep = "grep --color";
16 j = "sudo journalctl -u";
17 jb = "sudo journalctl -b";
18 l = "ls -alh";
19 ll = "ls -al";
20 ls = "ls --color=tty";
21 md-toc = "grep '^#\\+' --color";
22 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
23 mem-top = "smem --sort rss --autosize";
24 mpl = "mplayer";
25 nf = "sudo nft list ruleset | less";
26 nixos-clean = "sudo nix-collect-garbage -d";
27 nixos-history = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
28 nixos-rollback = "sudo nixos-rebuild switch --rollback";
29 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
30 r = "reset";
31 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
32 s = "sudo systemctl";
33 st = "sudo systemctl status";
34 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
35 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
36 u = "systemctl --user";
37 ut = "systemctl --user status";
38 w1 = "watch --color --differences --interval 1";
39 w5 = "watch --color --differences --interval 5";
40 w10 = "watch --color --differences --interval 10";
41 w = "watch --color --differences";
42 watch = "watch --color --differences";
43 yt = "yt-dlp";
44 zfs-umount = "zfs-unmount";
45 };
46 sessionVariables = {
47 HISTCONTROL = "erasedups:ignorespace";
48 HISTSIZE = "42000";
49 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
50 };
51 initExtra = ''
52 # Alias completion
53 . ${pkgs.complete-alias}/bin/complete_alias
54 complete -F _complete_alias "''${!BASH_ALIASES[@]}"
55
56 shopt -s globstar
57 shopt -s histappend
58 shopt -s histreedit
59 shopt -s histverify
60 # Disable ctrl-s/ctrl-q flow control
61 stty -ixon
62
63 ibm-fan () {
64 if [ $# -gt 0 ]
65 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
66 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
67 fi
68 acpi -t
69 }
70 mkcd () {
71 mkdir -p "$1" &&
72 cd "$1"
73 }
74 mkpass () {
75 tr -d -C 'A-Za-z0-9' </dev/urandom | head -c 25 | xclip
76 }
77 smartctl-tbw () {
78 device=''${1:-/dev/sda}
79 sudo smartctl -A $device |
80 { awk '
81 $0 ~ /Power_On_Hours/ { poh=$10; printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25 }
82 $0 ~ /Total_LBAs_Written/ {
83 lbas = $10;
84 bytes = $10 * 512;
85 mb = bytes / 1024^2;
86 gb = bytes / 1024^3;
87 tb = bytes / 1024^4;
88 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
89 printf "mean writes per hour: / %.2f", mb/poh
90 }
91 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
92 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
93 '; echo; } |
94 sed -e 's:/:@:' |
95 sed -e "s\$^\$$device @ \$" |
96 column -ts@
97 }
98 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk "/MemAvailable/{ printf \"%d\n\", \$2 * $fac; }" </proc/meminfo)k; }
99 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
100 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
101 swaplist () {
102 lastpid=
103 swap=0
104 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
105 while IFS=: read -r file x size x
106 do
107 pid=''${file#/proc/}
108 pid=''${pid%/smaps}
109 size=''${size% kB}
110 size=''${size##* }
111 if test "$pid" = "$lastpid"
112 then swap=$(( swap + size ))
113 else
114 if test "$swap" -gt 0
115 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
116 fi
117 if test "$pid" = self
118 then break
119 else
120 lastpid=$pid
121 swap=$size
122 fi
123 fi
124 done |
125 sort -nk1,1
126 }
127 edit-in-commit () { $EDITOR $(git diff-tree --no-commit-id --name-only -r "$@"); }
128 edit-in-git-grep () { $EDITOR $(git grep --name-only --recursive "$@"); }
129 zfs-mount () {
130 for d in $(zfs list -rH -o name "$@"); do
131 mountpoint /mnt/"$d" ||
132 sudo zfs mount -l "$d"
133 done
134 }
135 zfs-unmount () { sudo zfs unmount -u "$@"; }
136
137 # Raw replicating an encrypted ZFS dataset
138 # changes the encryptionroot to itself.
139 # Use zfs-fix-encryptionroot $new_encryptionroot
140 # to restore the inheritance.
141 # Note that it needs to decrypt all those datasets.
142 zfs-fix-encryptionroot () {
143 zfs load-key "$1"
144 for i in $(zfs list -rHo name "$1" | tail -n +2); do
145 echo >&2 "$i"
146 test "$(zfs get -Ho value encryptionroot $i)" = "$1" ||
147 zfs change-key -li "$i"
148 done
149 }
150 '';
151 profileExtra = ''
152 '';
153 };
154 programs.direnv.enableBashIntegration = true;
155 #programs.broot.enableBashIntegration = true;
156 programs.readline = {
157 enable = mkDefault true;
158 includeSystemConfig = true;
159 bindings = {
160 # Up/Down
161 "\\e[A" = "history-search-backward";
162 "\\e[B" = "history-search-forward";
163
164 # Ctrl-Left/Ctrl-Right
165 "\\e[1;5C" = "forward-word";
166 "\\e[1;5D" = "backward-word";
167 "\\e[5C" = "forward-word";
168 "\\e[5D" = "backward-word";
169 "\\e\\e[C" = "forward-word";
170 "\\e\\e[D" = "backward-word";
171
172 # Home/End
173 "\\e[1~" = "beginning-of-line";
174 "\\e[4~" = "end-of-line";
175
176 # Delete/Insert
177 "\\e[3~" = "delete-char";
178 "\\e[2~" = "quoted-insert";
179
180 # For non RH/Debian xterm, can't hurt for RH/Debian xterm
181 "\\eOF" = "end-of-line";
182 "\\eOH" = "beginning-of-line";
183
184 # For freebsd console
185 "\\e[F" = "end-of-line";
186 "\\e[H" = "beginning-of-line";
187
188 # $if term=rxvt
189 "\\e[7~" = "beginning-of-line";
190 "\\e[8~" = "end-of-line";
191 "\\eOc" = "forward-word";
192 "\\eOd" = "backward-word";
193 # $endif
194 };
195 variables = {
196 # Be 8 bit clean.
197 input-meta = mkDefault true;
198 output-meta = mkDefault true;
199 colored-completion-prefix = mkDefault true;
200 colored-stats = mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
201 echo-control-characters = mkDefault true;
202 mark-symlinked-directories = mkDefault true;
203 menu-complete-display-prefix = mkDefault true;
204 show-all-if-ambiguous = mkDefault true;
205 show-all-if-unmodified = mkDefault true;
206 visible-stats = mkDefault false; # Append char to indicate type
207 enable-bracketed-paste = mkDefault true;
208 };
209 };
210 }