1 { config, lib, pkgs, hostName, ... }:
4 ../../nixos/profiles/hardware/X201.nix
5 ../../nixos/profiles/zfs.nix
6 ../../nixos/profiles/zramSwap.nix
11 canTouchEfiVariables = true;
12 efiSysMountPoint = "/boot/efi";
19 "/dev/disk/by-id/ata-Samsung_SSD_850_PRO_128GB_S1SMNSAFC36436X"
21 configurationLimit = 16;
25 #enableCryptodisk = true;
28 services.udev.extraRules = ''
29 ACTION=="add", SUBSYSTEM=="tty", KERNEL=="ttyUSB*", ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9204", RUN+="${pkgs.gobi_loader}/lib/udev/gobi_loader -2000 $env{DEVNAME} /home/julm/documents/thinkpad-x201/gobi"
34 { device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
37 fileSystems."/boot/efi" =
38 { device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
42 { device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
45 cipher = "aes-xts-plain64";
46 source = "/dev/urandom";
51 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
52 # You should try to make this id unique among your hosts.
53 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
54 networking.hostId = "ce53d0c3";
56 boot.supportedFilesystems = [ "ntfs" "vfat" ];
58 powerManagement.powertop.enable = true;
59 #services.fprintd.enable = true;
62 { device = "${hostName}/root";
66 { device = "${hostName}/nix";
70 { device = "${hostName}/var";